summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGpower2 <arslanoglou.georgios@gmail.com>2016-10-07 12:11:48 +0300
committerGpower2 <arslanoglou.georgios@gmail.com>2016-10-07 12:11:48 +0300
commit8fc29168af14ed8c1e91ae4697f5506e1509ccbf (patch)
treec3dc89957605cb7ecbb04bc601abe43e46902c8a /configure.in
parent16d18d843fdbab5ba812b7e4db31ce235579a3f7 (diff)
downloadpalemoon-gre-8fc29168af14ed8c1e91ae4697f5506e1509ccbf.tar.gz
Remove d3dcompiler_43 from build system
- Remove MOZ_FOUND_BOTH_D3D_COMPILERS and MOZ_REQUIRE_ALL_D3DCS - Remove --enable-require-all-d3dc-versions , require-all-d3dc-versions and --enable-require-all-d3dc-versions - Remove MOZ_D3DCOMPILER_XP_DLL, MOZ_D3DCOMPILER_XP_CAB and DMOZ_D3DCOMPILER_XP_DLL
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 0 insertions, 24 deletions
diff --git a/configure.in b/configure.in
index c92f60706..167dde250 100644
--- a/configure.in
+++ b/configure.in
@@ -5787,8 +5787,6 @@ MOZ_HAS_WINSDK_WITH_D3D=
MOZ_D3DCOMPILER_VISTA_DLL=
MOZ_D3DCOMPILER_VISTA_DLL_PATH=
MOZ_DIRECTX_SDK_PATH=
-MOZ_D3DCOMPILER_XP_DLL=
-MOZ_D3DCOMPILER_XP_CAB=
case "$target_os" in
*mingw*)
@@ -5806,11 +5804,6 @@ x86_64)
;;
esac
-MOZ_ARG_ENABLE_BOOL(require-all-d3dc-versions,
-[ --enable-require-all-d3dc-versions Require all versions of the D3D compiler needed for supported Windows systems.],
- MOZ_REQUIRE_ALL_D3DCS=1,
- MOZ_REQUIRE_ALL_D3DCS=)
-
# This is potentially set in external mozconfig files; if it's set,
# then the build exposes the "webgl" context name, which is reserved
# for conformant implementations.
@@ -5870,31 +5863,16 @@ if test -n "$MOZ_ANGLE_RENDERER"; then
######################################
# Check that we found what we needed.
MOZ_FOUND_A_D3D_COMPILER=
- MOZ_FOUND_BOTH_D3D_COMPILERS=1
if test -n "$MOZ_D3DCOMPILER_VISTA_DLL"; then
MOZ_FOUND_A_D3D_COMPILER=1
AC_MSG_RESULT([Found d3dcompiler DLL for Vista+: $MOZ_D3DCOMPILER_VISTA_DLL])
- else
- MOZ_FOUND_BOTH_D3D_COMPILERS=
- fi
-
- if test -n "$MOZ_D3DCOMPILER_XP_DLL"; then
- MOZ_FOUND_A_D3D_COMPILER=1
- AC_MSG_RESULT([Found d3dcompiler DLL for XP: $MOZ_D3DCOMPILER_XP_DLL])
- else
- MOZ_FOUND_BOTH_D3D_COMPILERS=
fi
if test -z "$CROSS_COMPILE"; then
if test -z "MOZ_FOUND_A_D3D_COMPILER"; then
AC_MSG_ERROR([Couldn't find an acceptable D3D compiler DLL.])
fi
-
- if test -n "$MOZ_REQUIRE_ALL_D3DCS" -a -z "$MOZ_FOUND_BOTH_D3D_COMPILERS"; then
- AC_MSG_ERROR([Both D3D compilers _43 and _46+ are required by --enable-require-d3d-compilers.])
- AC_MSG_ERROR([ Install Windows SDK 8.0+, as well as DirectX SDK (June 2010 version or newer), or reconfigure without this flag.])
- fi
fi
fi
@@ -8313,8 +8291,6 @@ AC_SUBST(MOZ_HAS_WINSDK_WITH_D3D)
AC_SUBST(MOZ_D3DCOMPILER_VISTA_DLL)
AC_SUBST(MOZ_D3DCOMPILER_VISTA_DLL_PATH)
AC_SUBST(MOZ_DIRECTX_SDK_PATH)
-AC_SUBST(MOZ_D3DCOMPILER_XP_DLL)
-AC_SUBST(MOZ_D3DCOMPILER_XP_CAB)
AC_SUBST(MOZ_METRO)