summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGpower2 <arslanoglou.georgios@gmail.com>2016-10-01 23:46:22 +0300
committerGpower2 <arslanoglou.georgios@gmail.com>2016-10-01 23:46:22 +0300
commit16d18d843fdbab5ba812b7e4db31ce235579a3f7 (patch)
tree15edf3fceff0a21422b09e19000f949353ea02c4 /configure.in
parent363b55278026a0197f350a481debf1e689a1dc71 (diff)
downloadpalemoon-gre-16d18d843fdbab5ba812b7e4db31ce235579a3f7.tar.gz
Remove d3dcompiler_43 check in configure.in
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in54
1 files changed, 0 insertions, 54 deletions
diff --git a/configure.in b/configure.in
index de70dda29..c92f60706 100644
--- a/configure.in
+++ b/configure.in
@@ -5866,60 +5866,6 @@ if test -n "$MOZ_ANGLE_RENDERER"; then
MOZ_CHECK_HEADER(d3d10.h, MOZ_HAS_WINSDK_WITH_D3D=1)
fi
- ######################################
- # Find _43 for use by XP.
-
- if test "$HAVE_64BIT_BUILD"; then
- AC_MSG_RESULT([We are building a 64-bit binary, skip checking d3dcompiler_43.])
- else
- # Get the SDK path from the registry.
- # First try to get the June 2010 SDK
- MOZ_DIRECTX_SDK_REG_KEY=`reg query 'HKLM\Software\Microsoft\DirectX' //s | grep 'Microsoft DirectX SDK (June 2010)' | head -n 1`
- if test -z "$MOZ_DIRECTX_SDK_REG_KEY" ; then
- # Otherwise just take whatever comes first
- MOZ_DIRECTX_SDK_REG_KEY=`reg query 'HKLM\Software\Microsoft\DirectX' //s | grep 'Microsoft DirectX SDK' | head -n 1`
- fi
- MOZ_DIRECTX_SDK_PATH=`reg query "$MOZ_DIRECTX_SDK_REG_KEY" //v InstallPath | grep REG_SZ | sed 's/.*\([[a-zA-Z]]\)\\:\\\\/\\1\\:\\\\/' | sed 's,\\\\,/,g'`
-
- if test -n "$MOZ_DIRECTX_SDK_PATH" &&
- test -f "$MOZ_DIRECTX_SDK_PATH"/lib/$MOZ_D3D_CPU_SUFFIX/dxguid.lib ; then
- AC_MSG_RESULT([Found DirectX SDK via registry, using $MOZ_DIRECTX_SDK_PATH])
- else
- AC_MSG_RESULT([DirectX SDK not found.])
- MOZ_DIRECTX_SDK_PATH=
- fi
-
- # Check that our DirectX SDK is acceptable.
- if test -n "$MOZ_DIRECTX_SDK_PATH"; then
- if test -n "`echo $MOZ_DIRECTX_SDK_REG_KEY | grep 'February 2010'`" ; then
- AC_MSG_RESULT([Found the February 2010 DirectX SDK, which is unacceptable to ANGLE.])
- MOZ_DIRECTX_SDK_PATH=
- fi
- fi
-
- if test -n "$MOZ_DIRECTX_SDK_PATH"; then
- # Find a D3D compiler DLL in the DirectX SDK, if we didn't find one already.
- # Get the SDK numeric version (e.g. 43) by looking at the dependencies of d3dx9.lib
- MOZ_D3DX9_VERSION=`dumpbin //headers "$MOZ_DIRECTX_SDK_PATH"/lib/$MOZ_D3D_CPU_SUFFIX/d3dx9.lib | egrep d3dx9_[[0-9]][[0-9]]\.dll | head -n1 | sed 's/.*\([[0-9]][[0-9]]\).*/\\1/g'`
-
- if test -n "$MOZ_D3DX9_VERSION" ; then
- MOZ_D3DCOMPILER_XP_CAB=`find "$MOZ_DIRECTX_SDK_PATH"/Redist -name *D3DCompiler_${MOZ_D3DX9_VERSION}_${MOZ_D3D_CPU_SUFFIX}.cab | head -n1`
-
- if test -n "$MOZ_D3DCOMPILER_XP_CAB"; then
- MOZ_D3DCOMPILER_XP_DLL=D3DCompiler_$MOZ_D3DX9_VERSION.dll
- else
- AC_MSG_RESULT([Couldn't find a CAB containing the D3D compiler DLL.])
- AC_MSG_ERROR([DirectX SDK at "$MOZ_DIRECTX_SDK_PATH" appears broken.])
- MOZ_DIRECTX_SDK_PATH=
- fi
- else
- AC_MSG_RESULT([Couldn't determine the D3DX9 version for the DirectX SDK.])
- MOZ_DIRECTX_SDK_PATH=
- fi
- else
- AC_MSG_RESULT([Couldn't find an acceptable DirectX SDK for ANGLE, needed for d3dcompiler_43.])
- fi
- fi
######################################
# Check that we found what we needed.