summaryrefslogtreecommitdiff
path: root/python/python-pydns
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-pydns')
-rw-r--r--python/python-pydns/README1
-rw-r--r--python/python-pydns/python-pydns.SlackBuild94
-rw-r--r--python/python-pydns/python-pydns.info10
-rw-r--r--python/python-pydns/slack-desc19
4 files changed, 0 insertions, 124 deletions
diff --git a/python/python-pydns/README b/python/python-pydns/README
deleted file mode 100644
index 3e7fd0524a..0000000000
--- a/python/python-pydns/README
+++ /dev/null
@@ -1 +0,0 @@
-PyDNS provides a module for performing DNS queries from python applications.
diff --git a/python/python-pydns/python-pydns.SlackBuild b/python/python-pydns/python-pydns.SlackBuild
deleted file mode 100644
index 816f2856f5..0000000000
--- a/python/python-pydns/python-pydns.SlackBuild
+++ /dev/null
@@ -1,94 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for DKIMproxy
-
-# Copyright 2010, Steven King <kingrst@gmail.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-pydns
-VERSION=${VERSION:-2.3.4}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-ORIGNAM=$(echo $PRGNAM | cut -f2 -d-)
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $ORIGNAM-$VERSION
-tar vxzf $CWD/$ORIGNAM-$VERSION.tar.gz
-cd $ORIGNAM-$VERSION
-
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-/usr/bin/python setup.py build
-
-/usr/bin/python setup.py install --root $PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-
-cp -a \
- CREDITS.txt PKG-INFO MANIFEST.in README-guido.txt README.txt pydns.spec python-pydns.spec \
- $PKG/usr/doc/$PRGNAM-$VERSION
-
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-pydns/python-pydns.info b/python/python-pydns/python-pydns.info
deleted file mode 100644
index 58b9e7c9bf..0000000000
--- a/python/python-pydns/python-pydns.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-pydns"
-VERSION="2.3.4"
-HOMEPAGE="https://sourceforge.net/projects/pydns"
-DOWNLOAD="https://downloads.sourceforge.net/pydns/pydns-2.3.4.tar.gz"
-MD5SUM="f2cd357a101ad7dd2b3f353a8dad51b8"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Steven King"
-EMAIL="kingrst@gmail.com"
diff --git a/python/python-pydns/slack-desc b/python/python-pydns/slack-desc
deleted file mode 100644
index 59aef9bac3..0000000000
--- a/python/python-pydns/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-pydns: python-pydns (Python DNS library)
-python-pydns:
-python-pydns: PyDNS provides a module for performing DNS queries from
-python-pydns: python applications.
-python-pydns:
-python-pydns: Homepage: https://sourceforge.net/projects/pydns/
-python-pydns:
-python-pydns:
-python-pydns:
-python-pydns:
-python-pydns: