summaryrefslogtreecommitdiff
path: root/python/BeautifulSoup4/BeautifulSoup4.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/BeautifulSoup4/BeautifulSoup4.SlackBuild')
-rw-r--r--python/BeautifulSoup4/BeautifulSoup4.SlackBuild33
1 files changed, 5 insertions, 28 deletions
diff --git a/python/BeautifulSoup4/BeautifulSoup4.SlackBuild b/python/BeautifulSoup4/BeautifulSoup4.SlackBuild
index 74338d9973..c47c5ef2ad 100644
--- a/python/BeautifulSoup4/BeautifulSoup4.SlackBuild
+++ b/python/BeautifulSoup4/BeautifulSoup4.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for BeautifulSoup4
# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
-# Copyright 2020-2021 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2020-2022 Isaac Yu <isaacyu1@isaacyu1.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,8 +26,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=BeautifulSoup4
-VERSION=${VERSION:-4.9.3}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-4.10.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -82,36 +82,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
-
-# Python 3 support (requires python3-soupsieve)
-# shaypal5 provided an example package check:
-# https://gist.github.com/shaypal5/d505af9953cd86f59c750fa600ee4ba6
-if $(python3 -c 'import pkgutil; exit(not pkgutil.find_loader("soupsieve"))'); then
-
- # Prepare another source tarball before building for Python 3
- cd $TMP
- rm -rf $SRCNAM-$VERSION
- tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
- cd $SRCNAM-$VERSION
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
- # Build for Python 3
- sed -i "s/-rfI/-rf/" convert-py3k
- sh convert-py3k
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.md COPYING.txt NEWS.txt TODO.txt doc/* $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md COPYING.txt LICENSE NEWS.txt TODO.txt doc/* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install