summaryrefslogtreecommitdiff
path: root/libraries/ClientForm/ClientForm.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/ClientForm/ClientForm.SlackBuild')
-rw-r--r--libraries/ClientForm/ClientForm.SlackBuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/libraries/ClientForm/ClientForm.SlackBuild b/libraries/ClientForm/ClientForm.SlackBuild
deleted file mode 100644
index aa5177eb8a..0000000000
--- a/libraries/ClientForm/ClientForm.SlackBuild
+++ /dev/null
@@ -1,60 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for ClientForm
-
-# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
-
-PRGNAM=ClientForm
-VERSION=${VERSION:-0.2.10}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-
-# Automatically determine the architecture we're building on:
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -eu
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Use system pysetuptools
-patch -p1 < $CWD/pysetuptools.diff
-
-python setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-mv testdata $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.txt *.html $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a test/test_clientform.py examples/* $PKG/usr/doc/$PRGNAM-$VERSION/testdata
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}