summaryrefslogtreecommitdiff
path: root/gis/osm2pgrouting/osm2pgrouting.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'gis/osm2pgrouting/osm2pgrouting.SlackBuild')
-rw-r--r--gis/osm2pgrouting/osm2pgrouting.SlackBuild18
1 files changed, 7 insertions, 11 deletions
diff --git a/gis/osm2pgrouting/osm2pgrouting.SlackBuild b/gis/osm2pgrouting/osm2pgrouting.SlackBuild
index 5abb5e0a6d..fd244c8b67 100644
--- a/gis/osm2pgrouting/osm2pgrouting.SlackBuild
+++ b/gis/osm2pgrouting/osm2pgrouting.SlackBuild
@@ -58,20 +58,16 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
-rm -rf $TMP/$PRGNAM-$VERSION
cd $TMP
-if [ -e $CWD/v$VERSION.tar.gz ]; then
- tar xvf $CWD/v$VERSION.tar.gz
-else
- tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-fi
-cd $PRGNAM-$VERSION
+rm -rf $PRGNAM-$PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
sed -i "s_/usr/share/bin_/usr/bin_" CMakeLists.txt
mkdir -p build