summaryrefslogtreecommitdiff
path: root/development
diff options
context:
space:
mode:
Diffstat (limited to 'development')
-rw-r--r--development/Jinja/Jinja.SlackBuild71
-rw-r--r--development/Jinja/Jinja.info8
-rw-r--r--development/Jinja/README6
-rw-r--r--development/Jinja/slack-desc19
4 files changed, 0 insertions, 104 deletions
diff --git a/development/Jinja/Jinja.SlackBuild b/development/Jinja/Jinja.SlackBuild
deleted file mode 100644
index 4a11a3c70a..0000000000
--- a/development/Jinja/Jinja.SlackBuild
+++ /dev/null
@@ -1,71 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for Jinja
-
-# Copyright (c) 2008 Javier Rojas <jerojasro@gmail.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# If there's a good way to make this build with an ARCH other than
-# the one on which it's being built, please clue me in --rworkman
-
-PRGNAM=Jinja
-VERSION=1.2
-ARCH=$(uname -m)
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
-fi
-
-set -e # Exit on most errors
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
-
-CFLAGS="$SLKCFLAGS" python setup.py bdist
-tar xvf dist/$PRGNAM-$VERSION.linux-$ARCH.tar.gz -C $PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS CHANGES LICENSE TODO $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-mv $PKG/usr/docs/* $PKG/usr/doc/$PRGNAM-$VERSION
-rmdir $PKG/usr/docs
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/development/Jinja/Jinja.info b/development/Jinja/Jinja.info
deleted file mode 100644
index f300f9841a..0000000000
--- a/development/Jinja/Jinja.info
+++ /dev/null
@@ -1,8 +0,0 @@
-PRGNAM="Jinja"
-VERSION="1.2"
-HOMEPAGE="http://jinja.pocoo.org/"
-DOWNLOAD="http://pypi.python.org/packages/source/J/Jinja/Jinja-1.2.tar.gz"
-MD5SUM="1235a005ade00b213800ff1e798c0241"
-MAINTAINER="Javier Rojas"
-EMAIL="jerojasro@gmail.com"
-APPROVED="rworkman"
diff --git a/development/Jinja/README b/development/Jinja/README
deleted file mode 100644
index eb7ae62251..0000000000
--- a/development/Jinja/README
+++ /dev/null
@@ -1,6 +0,0 @@
-Jinja is a sandboxed template engine written in pure Python licensed under the
-BSD license. It provides a Django-like non-XML syntax and compiles templates
-into executable python code. It's basically a combination of Django templates
-and python code.
-
-This requires the Python setuptools (pysetuptools at SlackBuilds.org).
diff --git a/development/Jinja/slack-desc b/development/Jinja/slack-desc
deleted file mode 100644
index d87fbdfb32..0000000000
--- a/development/Jinja/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler--------------------------------------------------------|
-Jinja: Jinja (Django template engine)
-Jinja:
-Jinja: Jinja is a sandboxed template engine written in pure Python licensed
-Jinja: under the BSD license. It provides a Django-like non-XML syntax and
-Jinja: compiles templates into executable python code. It's basically a
-Jinja: combination of Django templates and python code.
-Jinja:
-Jinja: Homepage: http://jinja.pocoo.org/
-Jinja:
-Jinja:
-Jinja: