summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--python/pygame/README9
-rw-r--r--python/pygame/pygame.SlackBuild7
2 files changed, 7 insertions, 9 deletions
diff --git a/python/pygame/README b/python/pygame/README
index a5a5eb6337..653401ddde 100644
--- a/python/pygame/README
+++ b/python/pygame/README
@@ -1,4 +1,5 @@
-Pygame is a set of Python modules designed for writing games. It is written
-on top of the excellent SDL library. This allows you to create fully
-featured games and multimedia programs in the python language. Pygame is
-highly portable and runs on nearly every platform and operating system.
+Pygame is a set of Python modules designed for writing games. It is
+written on top of the excellent SDL library. This allows you to create
+fully featured games and multimedia programs in the python language.
+Pygame is highly portable and runs on nearly every platform and
+operating system.
diff --git a/python/pygame/pygame.SlackBuild b/python/pygame/pygame.SlackBuild
index 89cd4697eb..2ea02df31e 100644
--- a/python/pygame/pygame.SlackBuild
+++ b/python/pygame/pygame.SlackBuild
@@ -78,15 +78,12 @@ sed -i '/^if "install"/,$d' setup.py
# Fix warning message for missings dependencies
patch -p1 < $CWD/config_unix.patch
-python -u buildconfig/config.py
+python2 -u buildconfig/config.py
CFLAGS="$SLKCFLAGS" \
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
-# Pythonn 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
CFLAGS="$SLKCFLAGS" \
python3 setup.py install --root=$PKG
-fi
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true