summaryrefslogtreecommitdiff
path: root/system/pass-import
diff options
context:
space:
mode:
authorB. Watson <yalhcru@gmail.com>2022-04-13 14:07:58 -0400
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-04-16 12:11:25 +0700
commit2aefecd1c71f0dcea0e7b1c04fedfb19805ed2c7 (patch)
tree7bc9ba8058397353001c6f28a148038018455de6 /system/pass-import
parent705d94c3006f82247a42a98df3a2b58ac71fdd0d (diff)
downloadslackbuilds-2aefecd1c71f0dcea0e7b1c04fedfb19805ed2c7.tar.gz
system/pass-import: Fix man page dir.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/pass-import')
-rw-r--r--system/pass-import/pass-import.SlackBuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/system/pass-import/pass-import.SlackBuild b/system/pass-import/pass-import.SlackBuild
index e68b9db372..d808d0d537 100644
--- a/system/pass-import/pass-import.SlackBuild
+++ b/system/pass-import/pass-import.SlackBuild
@@ -22,11 +22,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220301 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - move man pages to correct directory (/usr/man, not /usr/share/man).
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pass-import
VERSION=${VERSION:-3.2}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -75,17 +75,14 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 setup.py install --root=$PKG
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/share/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/share/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+mv $PKG/usr/share/man $PKG/usr/man
+gzip -9 $PKG/usr/man/man*/*
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a CHANGELOG.rst CONTRIBUTING.rst LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION