summaryrefslogtreecommitdiff
path: root/system/maxcso/install.patch
diff options
context:
space:
mode:
authorHunter Sezen <orbea@fredslev.dk>2018-11-26 21:13:11 +0000
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2018-12-01 07:27:46 +0700
commitd0a86a675fcde2c2eceb4734a379eb886b2fef0b (patch)
tree659f4f75a962ea16407dc633bc2e681e7415170e /system/maxcso/install.patch
parent42b072662123ff0dd58a4fcccf53d3bb63be4498 (diff)
downloadslackbuilds-d0a86a675fcde2c2eceb4734a379eb886b2fef0b.tar.gz
system/maxcso: Added (Fast cso compressor).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'system/maxcso/install.patch')
-rw-r--r--system/maxcso/install.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/system/maxcso/install.patch b/system/maxcso/install.patch
new file mode 100644
index 0000000000..f91f09eba9
--- /dev/null
+++ b/system/maxcso/install.patch
@@ -0,0 +1,35 @@
+From 06c234d2734a2f129aa5cbc1cf8332594813343d Mon Sep 17 00:00:00 2001
+From: orbea <orbea@fredslev.dk>
+Date: Thu, 22 Nov 2018 12:04:28 -0800
+Subject: [PATCH] Makefile: Add install and uninstall targets.
+
+---
+ Makefile | 11 +++++++++++
+ 1 file changed, 11 insertions(+)
+
+diff --git a/Makefile b/Makefile
+index e66826da..54a6489c 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,3 +1,6 @@
++PREFIX ?= /usr/local
++BINDIR ?= $(PREFIX)/bin
++
+ CC ?= gcc
+ CXX ?= g++
+
+@@ -29,6 +32,14 @@ maxcso: $(SRC_CXX_OBJ) $(CLI_CXX_OBJ) $(ZOPFLI_C_OBJ) 7zip/7zip.a
+ 7zip/7zip.a:
+ $(MAKE) -C 7zip 7zip.a
+
++install:
++ mkdir -p $(DESTDIR)$(BINDIR)
++ cp maxcso $(DESTDIR)$(BINDIR)
++ chmod 0755 $(DESTDIR)$(BINDIR)/maxcso
++
++uninstall:
++ rm -f $(DESTDIR)$(BINDIR)/maxcso
++
+ clean:
+ rm -f $(SRC_CXX_OBJ) $(CLI_CXX_OBJ) $(ZOPFLI_C_OBJ) maxcso
+ $(MAKE) -C 7zip clean