summaryrefslogtreecommitdiff
path: root/system/dahdi-complete/dahdi-complete.SlackBuild
diff options
context:
space:
mode:
authorMatteo Bernardini <ponce@slackbuilds.org>2021-10-23 14:16:11 +0200
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-10-27 08:40:40 +0700
commit1c55f39e4b7d0a45b9c1199d28dbf7db958c46d5 (patch)
tree201009ec2f6b43e75cde6e83f052ee9cc69ab2d9 /system/dahdi-complete/dahdi-complete.SlackBuild
parent5c3343a21d502cd4191efc1f1827cef98ef9469e (diff)
downloadslackbuilds-1c55f39e4b7d0a45b9c1199d28dbf7db958c46d5.tar.gz
system/dahdi-complete: Updated for version 20201116_5c840cf.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/dahdi-complete/dahdi-complete.SlackBuild')
-rw-r--r--system/dahdi-complete/dahdi-complete.SlackBuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/system/dahdi-complete/dahdi-complete.SlackBuild b/system/dahdi-complete/dahdi-complete.SlackBuild
index 89bcd3ee72..db7da3730d 100644
--- a/system/dahdi-complete/dahdi-complete.SlackBuild
+++ b/system/dahdi-complete/dahdi-complete.SlackBuild
@@ -12,7 +12,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=dahdi-complete
-VERSION=${VERSION:-3.1.0}
+VERSION=${VERSION:-20201116_5c840cf}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -61,9 +61,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $ARCHIVE_NAME-$VERSION+$VERSION
-tar zxvf $CWD/$ARCHIVE_NAME-$VERSION+$VERSION.tar.gz
-cd $ARCHIVE_NAME-$VERSION+$VERSION
+rm -rf $ARCHIVE_NAME-$VERSION
+tar xvf $CWD/$ARCHIVE_NAME-$VERSION.tar.?z
+cd $ARCHIVE_NAME-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -75,18 +75,21 @@ sed -i -e 's/ -Werror//' tools/acinclude.m4 tools/xpp/Makefile.am
sed -i -e 's/-Werror //' tools/Makefile.am
# Fix Perl install location (otherwise it installs to /usr/local/share/perl5)
-sed -i -e 's/sitelib/vendorlib/' linux/build_tools/live_dahdi tools/xpp/Makefile.am
+sed -i -e 's/sitelib/vendorlib/' linux/build_tools/live_dahdi tools/xpp/Makefile.am || exit 1
cd linux
# thanks Gentoo for the patches!
-for i in $CWD/patches/* ; do patch -p1 < $i ; done
+#for i in $CWD/patches/* ; do patch -p1 < $i ; done
make all
+make install DESTDIR=$PKG
cd ../tools
+# thanks debian for this patch!
+patch -p1 < $CWD/dahdi-tools-3.1.0-fno-common.patch
./bootstrap.sh
autoreconf -fi
CPPFLAGS="-I$(pwd)/../linux/include" \
-CFLAGS="$SLKCFLAGS -w -Wl,--allow-multiple-definition" \
+CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
@@ -101,7 +104,6 @@ CXXFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
cd ..
-make config DESTDIR=$PKG
mkdir -p $PKG/usr/share/perl5/vendor_perl
mv $PKG/usr/local/share/perl5/* $PKG/usr/share/perl5/vendor_perl/
@@ -113,7 +115,7 @@ for file in $(find . -type f); do
mv $file "$file.new"
done
-install -D -m 0644 $TMP/$ARCHIVE_NAME-$VERSION+$VERSION/tools/dahdi.init $PKG/etc/rc.d/rc.dahdi.new
+install -D -m 0644 $TMP/$ARCHIVE_NAME-$VERSION/tools/dahdi.init $PKG/etc/rc.d/rc.dahdi.new
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true