summaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorAndrew Clemons <andrew.clemons@gmail.com>2022-10-31 21:47:47 +0900
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-11-05 21:15:17 +0700
commitfcbdb7a3b4fa7bfef447be0884f463e382f7090c (patch)
tree64eeefa27248eafd6da48b04427cce19db2d4cfb /python
parentdec8501f219f266e072127476f278dadf52c0ccf (diff)
downloadslackbuilds-fcbdb7a3b4fa7bfef447be0884f463e382f7090c.tar.gz
python/python3-automat: Fix offline build.
If fixed this in 748383dcd0 by adding python-m2r as a dependency. This is correct since upstream's `setup_requires` declares m2r as a dependency: https://github.com/glyph/automat/blob/v20.2.0/setup.py#L27 If m2r is not installed, the build will try to download it. If this fails, the build fails. This means the package cannot be built without internet at the moment. ``` distutils.errors.DistutilsError: Command '['/usr/bin/python3', '-m', 'pip', '--disable-pip-version-check', 'wheel', '--no-deps', '-w', '/tmp/SBo/slackrepo.3Z4xrt/build_python3-automat/tmp0o3ejajj', '--quiet', 'm2r']' returned non-zero exit status 1. ``` In 96170348cc, a change was made to make m2r optional, but this does not work since it is still declared in setup.py. It should be optional, since it is only used for formatting the contents of README.md for use as long_description in setup and that is wrapped in a try / except and will use the raw, unformatted text of README.md if it is not found. So for this change, I have patched out the declaration of m2r in setup.py and you can now build the package without downloading things as root during the build. Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-automat/optional_m2r.diff11
-rw-r--r--python/python3-automat/python3-automat.SlackBuild3
2 files changed, 13 insertions, 1 deletions
diff --git a/python/python3-automat/optional_m2r.diff b/python/python3-automat/optional_m2r.diff
new file mode 100644
index 0000000000..87e0ddc6bd
--- /dev/null
+++ b/python/python3-automat/optional_m2r.diff
@@ -0,0 +1,11 @@
+diff -Naur Automat-20.2.0.orig/setup.py Automat-20.2.0/setup.py
+--- Automat-20.2.0.orig/setup.py 2020-02-17 04:33:10.000000000 +0900
++++ Automat-20.2.0/setup.py 2022-10-31 21:14:14.926665030 +0900
+@@ -24,7 +24,6 @@
+ package_dir={'automat': 'automat'},
+ setup_requires=[
+ 'setuptools-scm',
+- 'm2r',
+ ],
+ install_requires=[
+ "attrs>=19.2.0",
diff --git a/python/python3-automat/python3-automat.SlackBuild b/python/python3-automat/python3-automat.SlackBuild
index 5f2a7c887a..cb88118c7c 100644
--- a/python/python3-automat/python3-automat.SlackBuild
+++ b/python/python3-automat/python3-automat.SlackBuild
@@ -29,7 +29,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-automat
SRCNAM=Automat
VERSION=${VERSION:-20.2.0}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -75,6 +75,7 @@ cd $TMP
rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
+cat $CWD/optional_m2r.diff | patch -p1
chown -R root:root .
find -L . \