summaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorIsaac Yu <isaacyu1@isaacyu1.com>2022-10-08 01:24:11 -0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-10-10 23:34:34 +0700
commitb830d017cfac97dd14cd92a43a9db2ae29460537 (patch)
treef8e63639404fb8efe716124c8650408d201f79d7 /python
parent379b8ab73cbd89af7b3856bbe0218ea15af6aa42 (diff)
downloadslackbuilds-b830d017cfac97dd14cd92a43a9db2ae29460537.tar.gz
python/threadpoolctl: Change build method to python3-flit_core
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/threadpoolctl/threadpoolctl.SlackBuild16
-rw-r--r--python/threadpoolctl/threadpoolctl.info2
2 files changed, 4 insertions, 14 deletions
diff --git a/python/threadpoolctl/threadpoolctl.SlackBuild b/python/threadpoolctl/threadpoolctl.SlackBuild
index cc36667352..24a6352681 100644
--- a/python/threadpoolctl/threadpoolctl.SlackBuild
+++ b/python/threadpoolctl/threadpoolctl.SlackBuild
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=threadpoolctl
VERSION=${VERSION:-3.1.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -75,18 +75,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Use this setup.py shim:
-cat << EOF > setup.py
-from distutils.core import setup
-setup(name='${PRGNAM}',
- version='${VERSION}',
- py_modules=['${PRGNAM}'],
-)
-EOF
-
-# With the shim, it's a good idea to use "unshare -n" to prevent downloading
-# anything extra:
-unshare -n python3 setup.py install --root=$PKG || exit 1
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/threadpoolctl/threadpoolctl.info b/python/threadpoolctl/threadpoolctl.info
index b37330d661..3905b31b43 100644
--- a/python/threadpoolctl/threadpoolctl.info
+++ b/python/threadpoolctl/threadpoolctl.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://files.pythonhosted.org/packages/source/t/threadpoolctl/threadp
MD5SUM="e278b89038d9c9b39e7afafb8f5f87a3"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-build python3-flit_core"
MAINTAINER="Isaac Yu"
EMAIL="isaacyu1@isaacyu1.com"