summaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorDave Woodfall <dave@slackbuilds.org>2021-05-06 17:11:18 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-08 01:41:49 +0700
commit3635a560db742506639b41e3967acb783b6d906f (patch)
tree7a940a7491044efb13aae1844c0b40d172276bdb /python
parentc6830b5760af44e674cb97ec71e3f14132bd70ff (diff)
downloadslackbuilds-3635a560db742506639b41e3967acb783b6d906f.tar.gz
python/python-lazy-object-proxy: Renamed python2-lazy-object-proxy.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-lazy-object-proxy/slack-desc19
-rw-r--r--python/python2-lazy-object-proxy/README (renamed from python/python-lazy-object-proxy/README)0
-rw-r--r--python/python2-lazy-object-proxy/python2-lazy-object-proxy.SlackBuild (renamed from python/python-lazy-object-proxy/python-lazy-object-proxy.SlackBuild)6
-rw-r--r--python/python2-lazy-object-proxy/python2-lazy-object-proxy.info (renamed from python/python-lazy-object-proxy/python-lazy-object-proxy.info)2
-rw-r--r--python/python2-lazy-object-proxy/slack-desc19
5 files changed, 23 insertions, 23 deletions
diff --git a/python/python-lazy-object-proxy/slack-desc b/python/python-lazy-object-proxy/slack-desc
deleted file mode 100644
index 00e813c3e5..0000000000
--- a/python/python-lazy-object-proxy/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-lazy-object-proxy: python-lazy-object-proxy (Python lazy object proxy)
-python-lazy-object-proxy:
-python-lazy-object-proxy: A fast and thorough lazy object proxy.
-python-lazy-object-proxy:
-python-lazy-object-proxy: Homepage: https://github.com/ionelmc/python-lazy-object-proxy
-python-lazy-object-proxy:
-python-lazy-object-proxy:
-python-lazy-object-proxy:
-python-lazy-object-proxy:
-python-lazy-object-proxy:
-python-lazy-object-proxy:
diff --git a/python/python-lazy-object-proxy/README b/python/python2-lazy-object-proxy/README
index 3cc4c3db0b..3cc4c3db0b 100644
--- a/python/python-lazy-object-proxy/README
+++ b/python/python2-lazy-object-proxy/README
diff --git a/python/python-lazy-object-proxy/python-lazy-object-proxy.SlackBuild b/python/python2-lazy-object-proxy/python2-lazy-object-proxy.SlackBuild
index cc5c87785e..f1fc34a351 100644
--- a/python/python-lazy-object-proxy/python-lazy-object-proxy.SlackBuild
+++ b/python/python2-lazy-object-proxy/python2-lazy-object-proxy.SlackBuild
@@ -22,8 +22,8 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-PRGNAM=python-lazy-object-proxy
-SRCNAM=$(echo $PRGNAM | cut -c8-24)
+PRGNAM=python2-lazy-object-proxy
+SRCNAM=$( echo $PRGNAM | cut -d- -f2- )
VERSION=${VERSION:-1.4.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -70,7 +70,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python-lazy-object-proxy/python-lazy-object-proxy.info b/python/python2-lazy-object-proxy/python2-lazy-object-proxy.info
index d169cec42f..cd5a12ae4f 100644
--- a/python/python-lazy-object-proxy/python-lazy-object-proxy.info
+++ b/python/python2-lazy-object-proxy/python2-lazy-object-proxy.info
@@ -1,4 +1,4 @@
-PRGNAM="python-lazy-object-proxy"
+PRGNAM="python2-lazy-object-proxy"
VERSION="1.4.0"
HOMEPAGE="https://github.com/ionelmc/python-lazy-object-proxy"
DOWNLOAD="https://files.pythonhosted.org/packages/ba/bd/c259aae1ef43cd887e08959b70768861272e65c7a0fd44c66864bcc585f4/lazy-object-proxy-1.4.0.tar.gz"
diff --git a/python/python2-lazy-object-proxy/slack-desc b/python/python2-lazy-object-proxy/slack-desc
new file mode 100644
index 0000000000..099416f73c
--- /dev/null
+++ b/python/python2-lazy-object-proxy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-lazy-object-proxy: python2-lazy-object-proxy (Python lazy object proxy)
+python2-lazy-object-proxy:
+python2-lazy-object-proxy: A fast and thorough lazy object proxy.
+python2-lazy-object-proxy:
+python2-lazy-object-proxy: Homepage: https://github.com/ionelmc/python2-lazy-object-proxy
+python2-lazy-object-proxy:
+python2-lazy-object-proxy:
+python2-lazy-object-proxy:
+python2-lazy-object-proxy:
+python2-lazy-object-proxy:
+python2-lazy-object-proxy: