summaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorDave Woodfall <dave@slackbuilds.org>2021-05-06 17:11:13 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-08 01:41:47 +0700
commit2736c86213709c55205311ac6b56905d1315b6db (patch)
treea0650dbe3663e9292b1678ed370aca559fdc55a2 /python
parentfd743313af52c72de96b367b50e3d2ec9808cfd1 (diff)
downloadslackbuilds-2736c86213709c55205311ac6b56905d1315b6db.tar.gz
python/python-cheetah: Renamed python2-cheetah.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-cheetah/slack-desc19
-rw-r--r--python/python2-cheetah/README (renamed from python/python-cheetah/README)0
-rw-r--r--python/python2-cheetah/python2-cheetah.SlackBuild (renamed from python/python-cheetah/python-cheetah.SlackBuild)10
-rw-r--r--python/python2-cheetah/python2-cheetah.info (renamed from python/python-cheetah/python-cheetah.info)2
-rw-r--r--python/python2-cheetah/slack-desc19
5 files changed, 25 insertions, 25 deletions
diff --git a/python/python-cheetah/slack-desc b/python/python-cheetah/slack-desc
deleted file mode 100644
index 9d26e930ae..0000000000
--- a/python/python-cheetah/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-cheetah: python-cheetah (Python-Powered Template Engine)
-python-cheetah:
-python-cheetah: Cheetah is an open source template engine and code generation tool,
-python-cheetah: written in Python. It can be used standalone or combined with other
-python-cheetah: tools and frameworks. Web development is its principle use, but
-python-cheetah: Cheetah is very flexible and is also being used to generate C++ game
-python-cheetah: code, Java, sql, form emails and even Python code.
-python-cheetah:
-python-cheetah: Homepage: http://www.cheetahtemplate.org/
-python-cheetah:
-python-cheetah:
diff --git a/python/python-cheetah/README b/python/python2-cheetah/README
index f2276cedb2..f2276cedb2 100644
--- a/python/python-cheetah/README
+++ b/python/python2-cheetah/README
diff --git a/python/python-cheetah/python-cheetah.SlackBuild b/python/python2-cheetah/python2-cheetah.SlackBuild
index 48277b8530..1b2a97474c 100644
--- a/python/python-cheetah/python-cheetah.SlackBuild
+++ b/python/python2-cheetah/python2-cheetah.SlackBuild
@@ -4,7 +4,7 @@
# Written by Nikos Skalkotos (skalkoto@gmail.com)
-PRGNAM="python-cheetah"
+PRGNAM=python2-cheetah
VERSION=${VERSION:-2.4.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -13,7 +13,7 @@ SRCNAM=Cheetah
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -24,8 +24,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -54,7 +54,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python-cheetah/python-cheetah.info b/python/python2-cheetah/python2-cheetah.info
index 56044a6bab..a8ce182b24 100644
--- a/python/python-cheetah/python-cheetah.info
+++ b/python/python2-cheetah/python2-cheetah.info
@@ -1,4 +1,4 @@
-PRGNAM="python-cheetah"
+PRGNAM="python2-cheetah"
VERSION="2.4.4"
HOMEPAGE="http://www.cheetahtemplate.org/"
DOWNLOAD="https://pypi.python.org/packages/source/C/Cheetah/Cheetah-2.4.4.tar.gz"
diff --git a/python/python2-cheetah/slack-desc b/python/python2-cheetah/slack-desc
new file mode 100644
index 0000000000..a58251deb5
--- /dev/null
+++ b/python/python2-cheetah/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-cheetah: python2-cheetah (Python-Powered Template Engine)
+python2-cheetah:
+python2-cheetah: Cheetah is an open source template engine and code generation tool,
+python2-cheetah: written in Python. It can be used standalone or combined with other
+python2-cheetah: tools and frameworks. Web development is its principle use, but
+python2-cheetah: Cheetah is very flexible and is also being used to generate C++ game
+python2-cheetah: code, Java, sql, form emails and even Python code.
+python2-cheetah:
+python2-cheetah: Homepage: http://www.cheetahtemplate.org/
+python2-cheetah:
+python2-cheetah: