summaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-10-19 18:49:51 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-10-20 23:32:11 +0700
commit24bfee2b1f4c805e9e6463ebe45dd7a75f4cdf7d (patch)
tree4c2f8d7e0d3d10c0c365f810b06a8a08cc602321 /python
parentf14514794e910a2b38c684da5400fa29a59b03e8 (diff)
downloadslackbuilds-24bfee2b1f4c805e9e6463ebe45dd7a75f4cdf7d.tar.gz
python/python2-pyOpenSSL: Added (Python wrapper for OpenSSL)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python2-pyOpenSSL/README6
-rw-r--r--python/python2-pyOpenSSL/python2-pyOpenSSL.SlackBuild93
-rw-r--r--python/python2-pyOpenSSL/python2-pyOpenSSL.info10
-rw-r--r--python/python2-pyOpenSSL/slack-desc19
4 files changed, 128 insertions, 0 deletions
diff --git a/python/python2-pyOpenSSL/README b/python/python2-pyOpenSSL/README
new file mode 100644
index 0000000000..8a0cda45ec
--- /dev/null
+++ b/python/python2-pyOpenSSL/README
@@ -0,0 +1,6 @@
+Python wrapper around a small subset of the OpenSSL library. Includes:
+X509 Certificates, SSL Context objects, SSL Connection objects using
+Python sockets as transport layer. The Connection object wraps all the
+socket methods and can therefore be used in.
+
+This is the last version of pyOpenSSL that supports python2.
diff --git a/python/python2-pyOpenSSL/python2-pyOpenSSL.SlackBuild b/python/python2-pyOpenSSL/python2-pyOpenSSL.SlackBuild
new file mode 100644
index 0000000000..365877965c
--- /dev/null
+++ b/python/python2-pyOpenSSL/python2-pyOpenSSL.SlackBuild
@@ -0,0 +1,93 @@
+#!/bin/bash
+
+# Slackware build script for python2-pyOpenSSL
+#
+# Copyright 2022 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python2-pyOpenSSL
+SRCNAM=pyOpenSSL
+VERSION=${VERSION:-21.0.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -ar *.rst LICENSE doc/ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python2-pyOpenSSL/python2-pyOpenSSL.info b/python/python2-pyOpenSSL/python2-pyOpenSSL.info
new file mode 100644
index 0000000000..0672911287
--- /dev/null
+++ b/python/python2-pyOpenSSL/python2-pyOpenSSL.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-pyOpenSSL"
+VERSION="21.0.0"
+HOMEPAGE="https://pypi.python.org/pypi/pyOpenSSL"
+DOWNLOAD="https://files.pythonhosted.org/packages/54/9a/2a43c5dbf4507f86f7c43cba4195d5e25a81c988fd7b0ea779dfc9c6973f/pyOpenSSL-21.0.0.tar.gz"
+MD5SUM="2ec707d15b4e92f5ca5e46e5aab2f4ca"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python2-cryptography"
+MAINTAINER="Willy Sudiarto Raharjo"
+EMAIL="willysr@slackbuilds.org"
diff --git a/python/python2-pyOpenSSL/slack-desc b/python/python2-pyOpenSSL/slack-desc
new file mode 100644
index 0000000000..a7ade89813
--- /dev/null
+++ b/python/python2-pyOpenSSL/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-pyOpenSSL: python2-pyOpenSSL (Python wrapper for OpenSSL)
+python2-pyOpenSSL:
+python2-pyOpenSSL: This module is a rather thin wrapper around (a subset of) the OpenSSL
+python2-pyOpenSSL: library. With thin wrapper I mean that a lot of the object methods do
+python2-pyOpenSSL: nothing more than calling a corresponding function in the OpenSSL
+python2-pyOpenSSL: library
+python2-pyOpenSSL:
+python2-pyOpenSSL: https://pypi.python.org/pypi/pyOpenSSL
+python2-pyOpenSSL:
+python2-pyOpenSSL:
+python2-pyOpenSSL: