summaryrefslogtreecommitdiff
path: root/python/terminado/terminado.SlackBuild
diff options
context:
space:
mode:
authorBenjamin Trigona-Harany <bosth@alumni.sfu.ca>2019-04-28 19:36:06 -0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2019-05-04 09:06:48 +0700
commit72df19c4911f3e9a2975cfd7018b282e2238875b (patch)
tree8827739201615b86dd6d8b67790deddd4eb647bc /python/terminado/terminado.SlackBuild
parent891f49caf225892f2a6c5e17ae58bbdfa1c73924 (diff)
downloadslackbuilds-72df19c4911f3e9a2975cfd7018b282e2238875b.tar.gz
python/terminado: Updated for version 0.8.2.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'python/terminado/terminado.SlackBuild')
-rw-r--r--python/terminado/terminado.SlackBuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/python/terminado/terminado.SlackBuild b/python/terminado/terminado.SlackBuild
index b1bc9f5e62..94bb2da8d4 100644
--- a/python/terminado/terminado.SlackBuild
+++ b/python/terminado/terminado.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for terminado
-# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=terminado
-VERSION=${VERSION:-0.8.1}
+VERSION=${VERSION:-0.8.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,7 +69,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true