summaryrefslogtreecommitdiff
path: root/python/subprocess32/subprocess32.SlackBuild
diff options
context:
space:
mode:
authorSerban Udrea <S.Udrea@gsi.de>2022-11-05 13:31:35 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-11-05 13:31:35 +0700
commitcf4981789bcc17b944727fecfe34e71617870329 (patch)
tree3c43cb11de219c4d5ad8ccd9f34b550ffe95f34a /python/subprocess32/subprocess32.SlackBuild
parent31e7221f62e691df1b6b1da24ac2be9b589b6dbf (diff)
downloadslackbuilds-cf4981789bcc17b944727fecfe34e71617870329.tar.gz
python/subprocess32: Updated for version 3.5.4.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/subprocess32/subprocess32.SlackBuild')
-rw-r--r--python/subprocess32/subprocess32.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/python/subprocess32/subprocess32.SlackBuild b/python/subprocess32/subprocess32.SlackBuild
index f7d44f8c58..48b6102f1e 100644
--- a/python/subprocess32/subprocess32.SlackBuild
+++ b/python/subprocess32/subprocess32.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for subprocess32
-# Copyright 2018 Serban Udrea <s.udrea@gsi.de>
+# Copyright 2018-2022 Serban Udrea <s.udrea@gsi.de>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification,
@@ -26,8 +26,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=subprocess32
-VERSION=${VERSION:-3.5.2}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-3.5.4}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -66,7 +66,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root $PKG
+python2 setup.py install --root $PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true