summaryrefslogtreecommitdiff
path: root/python/pymysql/pymysql.SlackBuild
diff options
context:
space:
mode:
authorLarry Hajali <larryhaja[at]gmail[dot]com>2015-09-17 22:37:08 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2015-09-17 22:37:08 +0700
commitb14979cbd611981f76cb57353f541fbe210d51fd (patch)
tree428da28806ef0bc8f373ccd98fc28a22009ad111 /python/pymysql/pymysql.SlackBuild
parent68fbd7b4155fbe43f05260b5dbc566d19cddb07d (diff)
downloadslackbuilds-b14979cbd611981f76cb57353f541fbe210d51fd.tar.gz
python/pymysql: Updated for version 0.6.6.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/pymysql/pymysql.SlackBuild')
-rw-r--r--python/pymysql/pymysql.SlackBuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/python/pymysql/pymysql.SlackBuild b/python/pymysql/pymysql.SlackBuild
index e497f1b928..6ed7796818 100644
--- a/python/pymysql/pymysql.SlackBuild
+++ b/python/pymysql/pymysql.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pymysql
-# Copyright 2014 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2014-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pymysql
-VERSION=${VERSION:-0.6.2}
+VERSION=${VERSION:-0.6.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -46,20 +46,24 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf PyMySQL-$PRGNAM-$VERSION
-tar xvf $CWD/PyMySQL-$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/PyMySQL-$PRGNAM-$VERSION.tar.gz 2>/dev/null || tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd PyMySQL-$PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Don't install tests.
rm -rf $PRGNAM/tests
python setup.py install --root=$PKG
+if [ "${PYTHON3:-no}" == "yes" ]; then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true