summaryrefslogtreecommitdiff
path: root/python/lxml/lxml.SlackBuild
diff options
context:
space:
mode:
authorLarry Hajali <larryhaja[at]gmail[dot]com>2018-11-18 15:52:11 -0800
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2018-11-24 12:35:19 +0700
commit2005e827de03a9a6381c25712086972b0061b03f (patch)
treee67800ff1721f9b67bca5dd03a6d708c1f22d871 /python/lxml/lxml.SlackBuild
parentb8562092d77a4adcd558b766e105d65a8a97e527 (diff)
downloadslackbuilds-2005e827de03a9a6381c25712086972b0061b03f.tar.gz
python/lxml: Add python3 bindings by default
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com>
Diffstat (limited to 'python/lxml/lxml.SlackBuild')
-rw-r--r--python/lxml/lxml.SlackBuild6
1 files changed, 2 insertions, 4 deletions
diff --git a/python/lxml/lxml.SlackBuild b/python/lxml/lxml.SlackBuild
index df1ee9fe02..ed6222ed25 100644
--- a/python/lxml/lxml.SlackBuild
+++ b/python/lxml/lxml.SlackBuild
@@ -68,10 +68,8 @@ find -L . \
python2 setup.py build --with-unicode-strings
python2 setup.py install --skip-build --root=$PKG
-if [ "${PYTHON3:-no}" == "yes" ]; then
- python3 setup.py build --with-unicode-strings
- python3 setup.py install --skip-build --root=$PKG
-fi
+python3 setup.py build --with-unicode-strings
+python3 setup.py install --skip-build --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true