summaryrefslogtreecommitdiff
path: root/libraries/libappindicator3/libappindicator3.SlackBuild
diff options
context:
space:
mode:
authorDavid Woodfall <dave@dawoodfall.net>2017-10-24 00:33:37 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2017-10-28 07:06:56 +0700
commit4d635ee499b92b309dff0e2482a1a3f228c34862 (patch)
tree7a621968272bb2e95133d4dc61756837a50fa23e /libraries/libappindicator3/libappindicator3.SlackBuild
parent9e2a6d6306860c544147e60d1ed001adc38c3fb0 (diff)
downloadslackbuilds-4d635ee499b92b309dff0e2482a1a3f228c34862.tar.gz
libraries/libappindicator3: Added (Menu Library).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'libraries/libappindicator3/libappindicator3.SlackBuild')
-rw-r--r--libraries/libappindicator3/libappindicator3.SlackBuild129
1 files changed, 129 insertions, 0 deletions
diff --git a/libraries/libappindicator3/libappindicator3.SlackBuild b/libraries/libappindicator3/libappindicator3.SlackBuild
new file mode 100644
index 0000000000..83f9670d83
--- /dev/null
+++ b/libraries/libappindicator3/libappindicator3.SlackBuild
@@ -0,0 +1,129 @@
+#!/bin/sh
+
+# Slackware build script for libappindicator
+# Copyright 2017 David Woodfall <dave@dawoodfall.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=libappindicator3
+SRCNAM=libappindicator
+VERSION=${VERSION:-16.10}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Force autogen.sh to use gtk3 or it errors out
+patch -p1 --verbose < $CWD/patches/gtk3.patch
+
+# The next 3 patches shamelessly pinched from Arch
+patch -p1 --verbose < $CWD/patches/0001-Glib.Timeout-fix.patch
+patch -p1 --verbose < $CWD/patches/0002-Fix-mono-nunit-pkgconfig-name.patch
+patch -p1 --verbose < $CWD/patches/0003-Fix-Mono-assemblies-directory.patch
+
+# This one is also from Arch(ish), but had to be recreated best it could
+patch -p1 --verbose < $CWD/patches/improved-plasma-support.patch
+
+# Patch pinched from Gentoo
+patch -p1 --verbose < $CWD/patches/conditional-py-bindings.patch
+
+# Removed a function which had no declaration
+patch -p1 --verbose < $CWD/patches/badfunction.patch
+
+# Having mono or gtk-sharp installed kills this build
+patch -p1 --verbose < $CWD/patches/disable-mono.patch
+
+# Don't use -Werror
+sed -i -e 's/ -Werror//' src/Makefile.am
+
+./autogen.sh
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS -std=c++11" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --with-gtk=3 \
+ --disable-mono-test \
+ --disable-static \
+ --disable-gtk-doc-html \
+ --disable-tests \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS COPYING COPYING.LGPL.2.1 ChangeLog NEWS README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}