summaryrefslogtreecommitdiff
path: root/games/fgrun/patches
diff options
context:
space:
mode:
authorMatteo Bernardini <ponce@slackbuilds.org>2013-11-18 18:29:01 +0100
committerRobby Workman <rworkman@slackbuilds.org>2013-11-19 01:10:58 -0600
commit83940e056e4dc987a0f61cf79bbc3316e0e5e3d7 (patch)
treed1327d6e5427cda4db246505c4b5afae0f1af8e7 /games/fgrun/patches
parentbcdc93d0d4cb91d7418c5c6c9654c733fc616c6f (diff)
downloadslackbuilds-83940e056e4dc987a0f61cf79bbc3316e0e5e3d7.tar.gz
games/fgrun: Updated for version 20131117_973f772.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'games/fgrun/patches')
-rw-r--r--games/fgrun/patches/fgrun-1.6.1-fix-crash-when-setting-defaults.patch18
-rw-r--r--games/fgrun/patches/fgrun-1.6.2-fix-reloadpath-logic.patch11
-rw-r--r--games/fgrun/patches/fgrun-1.7.0-update-required-SimGear-version.patch25
3 files changed, 54 insertions, 0 deletions
diff --git a/games/fgrun/patches/fgrun-1.6.1-fix-crash-when-setting-defaults.patch b/games/fgrun/patches/fgrun-1.6.1-fix-crash-when-setting-defaults.patch
new file mode 100644
index 0000000000..52b56d4055
--- /dev/null
+++ b/games/fgrun/patches/fgrun-1.6.1-fix-crash-when-setting-defaults.patch
@@ -0,0 +1,18 @@
+--- fgrun-1.6.1/src/wizard_funcs.cxx.orig 2012-02-27 22:56:08.000000000 +0100
++++ fgrun-1.6.1/src/wizard_funcs.cxx 2012-03-21 21:00:52.072609457 +0100
+@@ -1200,7 +1200,6 @@ Wizard::~Wizard()
+ aircraft->clear();
+
+ delete logwin;
+- delete win;
+ delete adv;
+ }
+
+@@ -2265,7 +2264,6 @@ Wizard::reset_settings()
+ prefs.set( "time_of_day_value", "noon" );
+
+ aircraft->value( 0 );
+- preview->make_current();
+ preview->clear();
+ preview->redraw();
+
diff --git a/games/fgrun/patches/fgrun-1.6.2-fix-reloadpath-logic.patch b/games/fgrun/patches/fgrun-1.6.2-fix-reloadpath-logic.patch
new file mode 100644
index 0000000000..fb5622d872
--- /dev/null
+++ b/games/fgrun/patches/fgrun-1.6.2-fix-reloadpath-logic.patch
@@ -0,0 +1,11 @@
+--- fgrun-1.6.2/src/wizard_funcs.cxx.orig 2012-09-11 14:57:53.176639212 +0200
++++ fgrun-1.6.2/src/wizard_funcs.cxx 2012-09-11 15:11:35.995000085 +0200
+@@ -296,7 +296,7 @@
+ {
+ fg_scenery = buf;
+ }
+- else if (reloadPath && systemPrefs.get( "fg_scenery", buf, "", buflen-1))
++ else if (systemPrefs.get( "fg_scenery", buf, "", buflen-1))
+ {
+ fg_scenery = buf;
+ prefs.set("fg_scenery", buf);
diff --git a/games/fgrun/patches/fgrun-1.7.0-update-required-SimGear-version.patch b/games/fgrun/patches/fgrun-1.7.0-update-required-SimGear-version.patch
new file mode 100644
index 0000000000..9f37d95b25
--- /dev/null
+++ b/games/fgrun/patches/fgrun-1.7.0-update-required-SimGear-version.patch
@@ -0,0 +1,25 @@
+From 436f659bdcef3726ece7928e221ba7ea7805381e Mon Sep 17 00:00:00 2001
+From: Fabrice Bellet <fabrice@bellet.info>
+Date: Sun, 22 Sep 2013 12:55:33 +0200
+Subject: [PATCH 5/5] Update required SimGear version
+
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index aa95c59..4b6fea5 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -131,7 +131,7 @@ find_package(Boost REQUIRED)
+ find_package(ZLIB REQUIRED)
+ find_package(FLTK REQUIRED)
+ find_package(OpenSceneGraph 2.8.1 REQUIRED osgText osgDB osgParticle osgUtil osgViewer osgGA)
+-find_package(SimGear 2.8.0 REQUIRED)
++find_package(SimGear 2.12.0 REQUIRED)
+ if (ENABLE_NLS)
+ find_package(Gettext)
+ endif (ENABLE_NLS)
+--
+1.8.3.1
+