summaryrefslogtreecommitdiff
path: root/desktop/redshift/redshift.SlackBuild
diff options
context:
space:
mode:
authorArTourter <artourter@gmail.com>2018-07-06 23:03:14 +0100
committerDavid Spencer <idlemoor@slackbuilds.org>2018-07-06 23:03:14 +0100
commit2dc18cf6b94fa33d281a7c3dcc66f79212fc368f (patch)
tree7221aaa3bbcb6a2ba6f17ec5bb3066fd94b5eccf /desktop/redshift/redshift.SlackBuild
parentb4971d6dbff02862997688d459cb786e9a550821 (diff)
downloadslackbuilds-2dc18cf6b94fa33d281a7c3dcc66f79212fc368f.tar.gz
desktop/redshift: Updated for version 1.12.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'desktop/redshift/redshift.SlackBuild')
-rw-r--r--desktop/redshift/redshift.SlackBuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/desktop/redshift/redshift.SlackBuild b/desktop/redshift/redshift.SlackBuild
index 52adf1313d..4c26391061 100644
--- a/desktop/redshift/redshift.SlackBuild
+++ b/desktop/redshift/redshift.SlackBuild
@@ -6,7 +6,7 @@
# Public domain, written 2010.
PRGNAM=redshift
-VERSION=${VERSION:-1.11}
+VERSION=${VERSION:-1.12}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
@@ -52,16 +52,20 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Geoclue2 should really be installed for full functionality but will compile
+# without it anyway if not.
if ! pkg-config --exists geoclue-2.0
then
CLUE2="--disable-geoclue2"
fi
-# build redshift-gtk, forcing python2
+# build redshift-gtk, forcing python2 if python3 is not present
# thanks to the fedora project for the patch
-sed -i 's/\(AM_PATH_PYTHON(\[\)3\.2/\12.7/' configure.ac
-sed -i 's/\(env python\)3/\1/' src/redshift-gtk/redshift-gtk.in
-autopoint -f && AUTOPOINT="intltoolize --automake --copy" autoreconf -vif
+if ! $(command -v python3 &>/dev/null); then
+ sed -i 's/\(AM_PATH_PYTHON(\[\)3\.2/\12.7/' configure.ac
+ sed -i 's/\(env python\)3/\1/' src/redshift-gtk/redshift-gtk.in
+ autopoint -f && AUTOPOINT="intltoolize --automake --copy" autoreconf -vif
+fi
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -86,7 +90,7 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING DESIGN HACKING README NEWS $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CONTRIBUTING.md COPYING DESIGN README-colorramp README NEWS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install