summaryrefslogtreecommitdiff
path: root/academic
diff options
context:
space:
mode:
authorIsaac Yu <isaacyu1@isaacyu1.com>2022-11-05 04:02:18 +0000
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-11-05 21:15:10 +0700
commitb9e67970f604db3d6d267a96a1d96a6e904e6398 (patch)
tree610711fed662eddd697045dcf913341519428a05 /academic
parentb7af108aa5a8b0ccffdd50718fb1e08c22a506c6 (diff)
downloadslackbuilds-b9e67970f604db3d6d267a96a1d96a6e904e6398.tar.gz
academic/python3-scipy: Added (py3 math, science, and engineering)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/python3-scipy/README27
-rw-r--r--academic/python3-scipy/python3-scipy.SlackBuild100
-rw-r--r--academic/python3-scipy/python3-scipy.info10
-rw-r--r--academic/python3-scipy/slack-desc19
4 files changed, 156 insertions, 0 deletions
diff --git a/academic/python3-scipy/README b/academic/python3-scipy/README
new file mode 100644
index 0000000000..74833a79a7
--- /dev/null
+++ b/academic/python3-scipy/README
@@ -0,0 +1,27 @@
+SciPy (pronounced "Sigh Pie") is open-source software for mathematics,
+science, and engineering.
+
+The SciPy library is built to work with NumPy arrays, and provides
+many user-friendly and efficient numerical routines such as routines
+for numerical integration and optimization. Together, they run on
+all popular operating systems, are quick to install, and are free of
+charge. NumPy and SciPy are easy to use, but powerful enough to be
+depended upon by some of the world's leading scientists and engineers.
+
+matplotlib and ipython are nice to have in connection with scipy, but
+scipy does not depend on them.
+
+Since ver. 0.14.0 scipy uses SuperLU instead of UMFPACK for solving
+unsymmetric sparse linear systems. If you want to use UMFPACK you
+must install it in advance of numpy and build numpy accordingly (see
+the README to numpy's SlackBuild). Moreover, after installing scipy,
+you have to install scikit-umfpack.
+
+If you need to build scipy for debugging, set DEBUG=y.
+
+NOTE: this is for Python 3. If you need Python 2 support, install
+python2-scipy.
+
+This script installs scipy ver. 1.9.1, the last possible version for
+Slackware 15.0. Newer versions require a newer Cython (as a build
+dependency).
diff --git a/academic/python3-scipy/python3-scipy.SlackBuild b/academic/python3-scipy/python3-scipy.SlackBuild
new file mode 100644
index 0000000000..7a2120c420
--- /dev/null
+++ b/academic/python3-scipy/python3-scipy.SlackBuild
@@ -0,0 +1,100 @@
+#!/bin/bash
+
+# Build script for the Python SciPy package to be used with python 3
+
+# Copyright 2016-2019 Serban Udrea <s.udrea@gsi.de>
+# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification,
+# is permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR
+# IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT,
+# INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+# SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+# HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
+# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
+# IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+# POSSIBILITY OF SUCH DAMAGE.
+
+# Written by Eugene Suter <easuter@gmail.com>
+# Updated to 0.7.2 by João Felipe Santos <joao.eel@gmail.com>
+# Updated up to 1.1.0 by Serban Udrea <S.Udrea@gsi.de>
+# Added support for building with debugging symbols (S. Udrea)
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM="python3-scipy"
+SRCNAM="scipy"
+VERSION=${VERSION:-1.9.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$PRGNAM}
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf "$SRCNAM-$VERSION"
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd "$SRCNAM-$VERSION"
+chown -R root:root .
+
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+DEBUG=${DEBUG:-no}
+DEBUG=$(echo "$DEBUG"|cut -b 1|tr a-z A-Z)
+
+if [ "$DEBUG" = "N" ]
+then
+ python3 setup.py install --root $PKG
+ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+else
+ python3 setup.py build --debug
+ python3 setup.py install --root $PKG
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE.txt HACKING.rst.txt PKG-INFO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc -type f -exec chmod 0644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/academic/python3-scipy/python3-scipy.info b/academic/python3-scipy/python3-scipy.info
new file mode 100644
index 0000000000..ce429b517e
--- /dev/null
+++ b/academic/python3-scipy/python3-scipy.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-scipy"
+VERSION="1.9.1"
+HOMEPAGE="https://www.scipy.org/"
+DOWNLOAD="https://github.com/scipy/scipy/releases/download/v1.9.1/scipy-1.9.1.tar.gz"
+MD5SUM="e6e70a9014dba74b4ef16686d23fd3ad"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-numpy lapack pybind11 python3-pythran"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu1@isaacyu1.com"
diff --git a/academic/python3-scipy/slack-desc b/academic/python3-scipy/slack-desc
new file mode 100644
index 0000000000..92ab6f1d7a
--- /dev/null
+++ b/academic/python3-scipy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-scipy: python3-scipy (python library for math, science, and engineering)
+python3-scipy:
+python3-scipy: The SciPy library is built to work with NumPy arrays, and provides
+python3-scipy: many user-friendly and efficient numerical routines such as routines
+python3-scipy: for numerical integration and optimization. Together, they run on all
+python3-scipy: popular operating systems, are quick to install, and are free of
+python3-scipy: charge. NumPy and SciPy are easy to use, but powerful enough to be
+python3-scipy: depended upon by some of the world's leading scientists and engineers.
+python3-scipy:
+python3-scipy: https://www.scipy.org/
+python3-scipy: