summaryrefslogtreecommitdiff
path: root/academic
diff options
context:
space:
mode:
authorSerban Udrea <S.Udrea@gsi.de>2022-11-05 04:14:15 +0000
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-11-05 21:15:10 +0700
commit2048ad0540b0222cb18f8b4d2a6d4c5ff857286e (patch)
treefe704558f49725129b7917c27732fc9b307f127d /academic
parentffb6b3d068792c6f51051fa18ee09596cb5ef484 (diff)
downloadslackbuilds-2048ad0540b0222cb18f8b4d2a6d4c5ff857286e.tar.gz
academic/python2-kiwisolver: Added (Cassowary algorithm)
Replacement for academic/kiwisolver Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/python2-kiwisolver/README8
-rw-r--r--academic/python2-kiwisolver/python2-kiwisolver.SlackBuild83
-rw-r--r--academic/python2-kiwisolver/python2-kiwisolver.info10
-rw-r--r--academic/python2-kiwisolver/slack-desc19
4 files changed, 120 insertions, 0 deletions
diff --git a/academic/python2-kiwisolver/README b/academic/python2-kiwisolver/README
new file mode 100644
index 0000000000..5a37c5dfc8
--- /dev/null
+++ b/academic/python2-kiwisolver/README
@@ -0,0 +1,8 @@
+This is an efficient C++ implementation of the Cassowary constraint
+solving algorithm. Kiwi(solver) is based on the seminal Cassowary
+paper. It is not a refactoring of the original C++ solver, but has been
+designed from the ground up to be lightweight and fast. It ranges from
+10x to 500x faster than the original Cassowary solver with typical use
+cases gaining a 40x improvement. Memory savings are consistently > 5x.
+
+Version 1.1.0 is the last one with support for python2.
diff --git a/academic/python2-kiwisolver/python2-kiwisolver.SlackBuild b/academic/python2-kiwisolver/python2-kiwisolver.SlackBuild
new file mode 100644
index 0000000000..33fb4073a3
--- /dev/null
+++ b/academic/python2-kiwisolver/python2-kiwisolver.SlackBuild
@@ -0,0 +1,83 @@
+#!/bin/bash
+
+# Slackware build script for kiwisolver
+
+# Copyright 2018-2022 Serban Udrea <s.udrea@gsi.de>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification,
+# is permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR
+# IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT,
+# INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+# SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+# HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
+# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
+# IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+# POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python2-kiwisolver
+SRCNAM=kiwisolver
+VERSION=${VERSION:-1.1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$PRGNAM}
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python2 setup.py install --root $PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a releasenotes.rst PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/academic/python2-kiwisolver/python2-kiwisolver.info b/academic/python2-kiwisolver/python2-kiwisolver.info
new file mode 100644
index 0000000000..875281ea80
--- /dev/null
+++ b/academic/python2-kiwisolver/python2-kiwisolver.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-kiwisolver"
+VERSION="1.1.0"
+HOMEPAGE="https://pypi.org/project/kiwisolver"
+DOWNLOAD="https://files.pythonhosted.org/packages/16/e7/df58eb8868d183223692d2a62529a594f6414964a3ae93548467b146a24d/kiwisolver-1.1.0.tar.gz"
+MD5SUM="fc8a614367f7ba0d34a02fd08c535afc"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Serban Udrea"
+EMAIL="S.Udrea@gsi.de"
diff --git a/academic/python2-kiwisolver/slack-desc b/academic/python2-kiwisolver/slack-desc
new file mode 100644
index 0000000000..ecf6335078
--- /dev/null
+++ b/academic/python2-kiwisolver/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-kiwisolver: python2-kiwisolver (an implementation of the Cassowary algorithm)
+python2-kiwisolver:
+python2-kiwisolver: This is an efficient C++ implementation of the Cassowary constraint
+python2-kiwisolver: solving algorithm. Kiwi(solver) is based on the seminal Cassowary
+python2-kiwisolver: paper. It is not a refactoring of the original C++ solver, but has
+python2-kiwisolver: been designed from the ground up to be lightweight and fast.
+python2-kiwisolver:
+python2-kiwisolver: Homepage: https://pypi.org/project/kiwisolver
+python2-kiwisolver:
+python2-kiwisolver: Version 1.1.0 is the last one with support for python2.
+python2-kiwisolver: