summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilly Sudiarto Raharjo <willysr@slackbuilds.org>2017-04-15 11:28:03 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2017-04-15 11:28:03 +0700
commitfc99516514f9aceb00c1f62564e3e0221a52a8be (patch)
treee42d7d75544bb25b10b78c03fa9637a866839589
parentc818fed917054ae503cd02044e9314e3ae4d51f8 (diff)
downloadslackbuilds-fc99516514f9aceb00c1f62564e3e0221a52a8be.tar.gz
network/qwit: Removed (No longer work).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--network/qwit/README1
-rw-r--r--network/qwit/doinst.sh3
-rw-r--r--network/qwit/qwit.SlackBuild88
-rw-r--r--network/qwit/qwit.info10
-rw-r--r--network/qwit/slack-desc19
5 files changed, 0 insertions, 121 deletions
diff --git a/network/qwit/README b/network/qwit/README
deleted file mode 100644
index 840d96d693..0000000000
--- a/network/qwit/README
+++ /dev/null
@@ -1 +0,0 @@
-Qwit - free cross-platform Qt4-based Twitter client.
diff --git a/network/qwit/doinst.sh b/network/qwit/doinst.sh
deleted file mode 100644
index 5fb28930db..0000000000
--- a/network/qwit/doinst.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
diff --git a/network/qwit/qwit.SlackBuild b/network/qwit/qwit.SlackBuild
deleted file mode 100644
index c182357134..0000000000
--- a/network/qwit/qwit.SlackBuild
+++ /dev/null
@@ -1,88 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for qwit
-
-# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
-
-PRGNAM=qwit
-VERSION=${VERSION:-1.1_pre2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-${VERSION/_/-}-src
-tar xvf $CWD/$PRGNAM-${VERSION/_/-}-src.tar.bz2
-cd $PRGNAM-${VERSION/_/-}-src
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Fix .desktop and CMakeLists.txt.
-sed -i '/^Categories/s|Internet||' $PRGNAM.desktop
-echo "StartupNotify=false" >> $PRGNAM.desktop
-sed -i \
- -e 's|\${QT_BINARY_DIR}|bin|' -e 's|/qca2||' \
- -e 's|/icons|/pixmaps|' CMakeLists.txt
-
-mkdir build
-cd build
- cmake -G "Unix Makefiles" \
- -DCMAKE_INSTALL_PREFIX:PATH="/usr" \
- -DLIB_SUFFIX="$LIBDIRSUFFIX" \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_BUILD_TYPE=Release ..
-
- make VERBOSE=1
- make install DESTDIR=$PKG
-cd ..
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS COPYING INSTALL README \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/qwit/qwit.info b/network/qwit/qwit.info
deleted file mode 100644
index 3aab1add6c..0000000000
--- a/network/qwit/qwit.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="qwit"
-VERSION="1.1_pre2"
-HOMEPAGE="http://code.google.com/p/qwit/"
-DOWNLOAD="http://qwit.googlecode.com/files/qwit-1.1-pre2-src.tar.bz2"
-MD5SUM="e8775236e5a8a83937bdf009193b7618"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="qoauth"
-MAINTAINER="Larry Hajali"
-EMAIL="larryhaja[at]gmail[dot]com"
diff --git a/network/qwit/slack-desc b/network/qwit/slack-desc
deleted file mode 100644
index ec4f9aa2a8..0000000000
--- a/network/qwit/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-qwit: qwit (Twitter client)
-qwit:
-qwit: Qwit - free cross-platform Qt4-based Twitter client.
-qwit:
-qwit: Homepage: http://code.google.com/p/qwit/
-qwit:
-qwit:
-qwit:
-qwit:
-qwit:
-qwit: