summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDave Woodfall <dave@slackbuilds.org>2022-05-20 21:35:20 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-05-21 08:25:31 +0700
commitc2a03e1466cad8b16c8e7ff80ce80b123442eb19 (patch)
tree6a7599072f8b98c6af190504603ff97b1ab95732
parent26978d00c34a5166baccb2f558aacbd93dcbe44c (diff)
downloadslackbuilds-c2a03e1466cad8b16c8e7ff80ce80b123442eb19.tar.gz
python/flask-paginate: Removed. Python3 script added.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/flask-paginate/README3
-rw-r--r--python/flask-paginate/flask-paginate.SlackBuild95
-rw-r--r--python/flask-paginate/flask-paginate.info10
-rw-r--r--python/flask-paginate/slack-desc19
4 files changed, 0 insertions, 127 deletions
diff --git a/python/flask-paginate/README b/python/flask-paginate/README
deleted file mode 100644
index 57908f43f9..0000000000
--- a/python/flask-paginate/README
+++ /dev/null
@@ -1,3 +0,0 @@
-Paginate support for flask framework (study from will_paginate). Use
-bootstrap for css framework. It requires Python2.6+ as string.format
-syntax.
diff --git a/python/flask-paginate/flask-paginate.SlackBuild b/python/flask-paginate/flask-paginate.SlackBuild
deleted file mode 100644
index dd084e70a4..0000000000
--- a/python/flask-paginate/flask-paginate.SlackBuild
+++ /dev/null
@@ -1,95 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for flask-paginate
-
-# Copyright 2016-2017 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=flask-paginate
-VERSION=${VERSION:-0.5.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/flask-paginate/flask-paginate.info b/python/flask-paginate/flask-paginate.info
deleted file mode 100644
index b6fabcf442..0000000000
--- a/python/flask-paginate/flask-paginate.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="flask-paginate"
-VERSION="0.5.0"
-HOMEPAGE="https://github.com/lixxu/flask-paginate"
-DOWNLOAD="https://pypi.python.org/packages/e6/f5/472e6038aa8cc707f44c1ca572164e72ac1bbe2b843ee7f9b0ed880a041c/flask-paginate-0.5.0.tar.gz"
-MD5SUM="e8b776299d5914226d9e130b822e68fb"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="Flask"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/flask-paginate/slack-desc b/python/flask-paginate/slack-desc
deleted file mode 100644
index 4079d20953..0000000000
--- a/python/flask-paginate/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-flask-paginate: flask-paginate (Simple paginate support for flask)
-flask-paginate:
-flask-paginate: Paginate support for flask framework (study from will_paginate).
-flask-paginate: Use bootstrap for css framework It requires Python2.6+ as
-flask-paginate: string.format syntax.
-flask-paginate:
-flask-paginate: Homepage: https://github.com/lixxu/flask-paginate
-flask-paginate:
-flask-paginate:
-flask-paginate:
-flask-paginate: