summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatteo Bernardini <ponce@slackbuilds.org>2022-02-03 20:05:49 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-02-04 17:53:40 +0700
commit7cc110eba600c7d6a6f2b27bad67dd97d48c8d45 (patch)
tree49a9093ff9d86b3eabb3997541f531a0e567c7bc
parent01c76519fe4474039454779bd4b9f2e6fb140ad3 (diff)
downloadslackbuilds-7cc110eba600c7d6a6f2b27bad67dd97d48c8d45.tar.gz
libraries/wangle: Removed (orphaned and FTB).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/wangle/README7
-rw-r--r--libraries/wangle/slack-desc19
-rw-r--r--libraries/wangle/wangle.SlackBuild110
-rw-r--r--libraries/wangle/wangle.info10
4 files changed, 0 insertions, 146 deletions
diff --git a/libraries/wangle/README b/libraries/wangle/README
deleted file mode 100644
index 906048204d..0000000000
--- a/libraries/wangle/README
+++ /dev/null
@@ -1,7 +0,0 @@
-Wangle is a framework providing a set of common client/server
-abstractions for building services in a consistent, modular,
-and composable way.
-
-Wangle is a library that makes it easy to build protocols,
-application clients, and application servers.
-It's like Netty + Finagle smooshed together, but in C++.
diff --git a/libraries/wangle/slack-desc b/libraries/wangle/slack-desc
deleted file mode 100644
index 3d68beb7d9..0000000000
--- a/libraries/wangle/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-wangle: wangle (C++ networking library)
-wangle:
-wangle: Wangle is a framework providing a set of common client/server
-wangle: abstractions for building services in a consistent, modular,
-wangle: and composable way.
-wangle:
-wangle:
-wangle:
-wangle:
-wangle: https://github.com/facebook/wangle
-wangle:
diff --git a/libraries/wangle/wangle.SlackBuild b/libraries/wangle/wangle.SlackBuild
deleted file mode 100644
index ca51baaa8f..0000000000
--- a/libraries/wangle/wangle.SlackBuild
+++ /dev/null
@@ -1,110 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for Wangle
-
-# Copyright 2016 Andre Barboza, Belo Horizonte - Brazil
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=wangle
-VERSION=${VERSION:-2017.09.25.00}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-pushd wangle
-sed -i -e "s#DESTINATION lib)#DESTINATION lib${LIBDIRSUFFIX})#" CMakeLists.txt
-
-mkdir -p build
-cd build
- cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DBUILD_SHARED_LIBS:BOOL=ON \
- -DBUILD_TESTS:BOOL=OFF ..
- make
- make install DESTDIR=$PKG
-cd ..
-popd
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CONTRIBUTING.md LICENSE README.md tutorial.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/wangle/wangle.info b/libraries/wangle/wangle.info
deleted file mode 100644
index c3422a7f8c..0000000000
--- a/libraries/wangle/wangle.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="wangle"
-VERSION="2017.09.25.00"
-HOMEPAGE="https://github.com/facebook/wangle"
-DOWNLOAD="UNSUPPORTED"
-MD5SUM=""
-DOWNLOAD_x86_64="https://github.com/facebook/wangle/archive/v2017.09.25.00/wangle-2017.09.25.00.tar.gz"
-MD5SUM_x86_64="af9cd0dfb1e40b1834da5a6f9d04bb66"
-REQUIRES="folly"
-MAINTAINER="Andre Barboza"
-EMAIL="bmg.andre@gmail.com"