summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDave Woodfall <dave@slackbuilds.org>2021-05-06 17:11:22 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-08 01:41:50 +0700
commit3e67a6714341deac3568c5a924d7f07f7e5d4cd7 (patch)
tree9dcb3af0c2ade43efc1a03ca588e0e2b57662f6b
parent3589b74c4679ad2d16d58f6790f58c02d377ccdc (diff)
downloadslackbuilds-3e67a6714341deac3568c5a924d7f07f7e5d4cd7.tar.gz
python/python-pydns: Renamed python2-pydns.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python-pydns/README1
-rw-r--r--python/python-pydns/slack-desc19
-rw-r--r--python/python2-pydns/README2
-rw-r--r--python/python2-pydns/python2-pydns.SlackBuild (renamed from python/python-pydns/python-pydns.SlackBuild)21
-rw-r--r--python/python2-pydns/python2-pydns.info (renamed from python/python-pydns/python-pydns.info)2
-rw-r--r--python/python2-pydns/slack-desc19
6 files changed, 32 insertions, 32 deletions
diff --git a/python/python-pydns/README b/python/python-pydns/README
deleted file mode 100644
index 3e7fd0524a..0000000000
--- a/python/python-pydns/README
+++ /dev/null
@@ -1 +0,0 @@
-PyDNS provides a module for performing DNS queries from python applications.
diff --git a/python/python-pydns/slack-desc b/python/python-pydns/slack-desc
deleted file mode 100644
index 59aef9bac3..0000000000
--- a/python/python-pydns/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-pydns: python-pydns (Python DNS library)
-python-pydns:
-python-pydns: PyDNS provides a module for performing DNS queries from
-python-pydns: python applications.
-python-pydns:
-python-pydns: Homepage: https://sourceforge.net/projects/pydns/
-python-pydns:
-python-pydns:
-python-pydns:
-python-pydns:
-python-pydns:
diff --git a/python/python2-pydns/README b/python/python2-pydns/README
new file mode 100644
index 0000000000..9e47f61a5e
--- /dev/null
+++ b/python/python2-pydns/README
@@ -0,0 +1,2 @@
+PyDNS provides a module for performing DNS queries from python
+applications.
diff --git a/python/python-pydns/python-pydns.SlackBuild b/python/python2-pydns/python2-pydns.SlackBuild
index 816f2856f5..c712cc1cbe 100644
--- a/python/python-pydns/python-pydns.SlackBuild
+++ b/python/python2-pydns/python2-pydns.SlackBuild
@@ -22,16 +22,16 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-PRGNAM=python-pydns
+PRGNAM=python2-pydns
VERSION=${VERSION:-2.3.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-ORIGNAM=$(echo $PRGNAM | cut -f2 -d-)
+SRCNAM=$( echo $PRGNAM | cut -f2 -d- )
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -42,8 +42,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -61,9 +61,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $ORIGNAM-$VERSION
-tar vxzf $CWD/$ORIGNAM-$VERSION.tar.gz
-cd $ORIGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar vxzf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
@@ -72,9 +72,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-/usr/bin/python setup.py build
-
-/usr/bin/python setup.py install --root $PKG
+python2 setup.py build
+python2 setup.py install --root $PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python-pydns/python-pydns.info b/python/python2-pydns/python2-pydns.info
index 58b9e7c9bf..c6e6ab5b53 100644
--- a/python/python-pydns/python-pydns.info
+++ b/python/python2-pydns/python2-pydns.info
@@ -1,4 +1,4 @@
-PRGNAM="python-pydns"
+PRGNAM="python2-pydns"
VERSION="2.3.4"
HOMEPAGE="https://sourceforge.net/projects/pydns"
DOWNLOAD="https://downloads.sourceforge.net/pydns/pydns-2.3.4.tar.gz"
diff --git a/python/python2-pydns/slack-desc b/python/python2-pydns/slack-desc
new file mode 100644
index 0000000000..97b10ec8bc
--- /dev/null
+++ b/python/python2-pydns/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-pydns: python2-pydns (Python DNS library)
+python2-pydns:
+python2-pydns: PyDNS provides a module for performing DNS queries from
+python2-pydns: python applications.
+python2-pydns:
+python2-pydns: Homepage: https://sourceforge.net/projects/pydns/
+python2-pydns:
+python2-pydns:
+python2-pydns:
+python2-pydns:
+python2-pydns: