summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobby Workman <rworkman@slackbuilds.org>2021-05-02 22:12:36 -0500
committerRobby Workman <rworkman@slackbuilds.org>2021-05-02 22:12:36 -0500
commit3a3c7923661ce8000081082bf192d0d73f4c432a (patch)
tree783143dacc1b1bb96af29d9eb5f99381b30fc8ca
parent92f61780f5fb3319d25342da34a183cc4cff78b2 (diff)
downloadslackbuilds-3a3c7923661ce8000081082bf192d0d73f4c432a.tar.gz
python/python-cmdln: Removed (abandoned upstream)
-rw-r--r--python/python-cmdln/README3
-rw-r--r--python/python-cmdln/python-cmdln.SlackBuild87
-rw-r--r--python/python-cmdln/python-cmdln.info10
-rw-r--r--python/python-cmdln/slack-desc19
4 files changed, 0 insertions, 119 deletions
diff --git a/python/python-cmdln/README b/python/python-cmdln/README
deleted file mode 100644
index af5dcdcb71..0000000000
--- a/python/python-cmdln/README
+++ /dev/null
@@ -1,3 +0,0 @@
-cmdln.py fixes some of the design flaws in cmd.py and takes advantage
-of new Python stdlib modules (e.g. optparse) so that it is more useful
-(and convenient) for implementing command-line scripts/shells.
diff --git a/python/python-cmdln/python-cmdln.SlackBuild b/python/python-cmdln/python-cmdln.SlackBuild
deleted file mode 100644
index 645bd3123b..0000000000
--- a/python/python-cmdln/python-cmdln.SlackBuild
+++ /dev/null
@@ -1,87 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-cmdln
-
-# Copyright 2011,2012 Robby Workman, Northport, Alabama, USA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-cmdln
-VERSION=${VERSION:-2.0.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRCNAM=cmdln
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.txt docs/* examples $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-cmdln/python-cmdln.info b/python/python-cmdln/python-cmdln.info
deleted file mode 100644
index a83defe0c6..0000000000
--- a/python/python-cmdln/python-cmdln.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-cmdln"
-VERSION="2.0.0"
-HOMEPAGE="https://github.com/trentm/cmdln"
-DOWNLOAD="https://github.com/trentm/cmdln/archive/2.0.0/cmdln-2.0.0.tar.gz"
-MD5SUM="4dc5de6ed8029ae39402102dd914f02d"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Robby Workman"
-EMAIL="rworkman@slackbuilds.org"
diff --git a/python/python-cmdln/slack-desc b/python/python-cmdln/slack-desc
deleted file mode 100644
index 4263d19c7c..0000000000
--- a/python/python-cmdln/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-cmdln: python-cmdln (enhanced cmdln module for python)
-python-cmdln:
-python-cmdln: cmdln.py fixes some of the design flaws in cmd.py and takes
-python-cmdln: advantage of new Python stdlib modules (e.g. optparse) so that
-python-cmdln: it is more useful (and convenient) for implementing command-line
-python-cmdln: scripts/shells.
-python-cmdln:
-python-cmdln:
-python-cmdln:
-python-cmdln:
-python-cmdln: