summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPale Moon <git-repo@palemoon.org>2016-09-18 16:31:18 +0200
committerPale Moon <git-repo@palemoon.org>2016-09-18 19:39:22 +0200
commitd4a4492c6588116d4888510cbb2e1db9ab077a24 (patch)
treef3da473a55aa40df490ba75afaca1a73449c3360 /configure.in
parent84fdad27f2a414e4ca5b0d682d50dc0e3fd2dca6 (diff)
downloadpalemoon-gre-d4a4492c6588116d4888510cbb2e1db9ab077a24.tar.gz
Don't build WebRTC code by default.
- Pale Moon users have clearly indicated they don't want WebRTC - WebRTC code includes a lot of potential security risks (including peer connection leaks) - WebRTC code relies on old and poorly-supported third party libs Can still be enabled with --enable-webrtc Potentially offer as an alt package in the future if demand is high?
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 4fc500c68..de70dda29 100644
--- a/configure.in
+++ b/configure.in
@@ -3860,7 +3860,7 @@ else
MOZ_FMP4=
fi
MOZ_FFMPEG=
-MOZ_WEBRTC=1
+MOZ_WEBRTC=
MOZ_PEERCONNECTION=
MOZ_SRTP=
MOZ_WEBRTC_SIGNALING=
@@ -5060,7 +5060,7 @@ dnl the master list above.
if test -n "$MOZ_WEBRTC"; then
case "$target" in
*-linux*|*-mingw*|*-darwin*|*-android*|*-linuxandroid*|*-dragonfly*|*-freebsd*|*-netbsd*|*-openbsd*)
- dnl Leave enabled
+ dnl Leave as default setting in master list
;;
*)
dnl default to disabled for all others
@@ -5093,12 +5093,12 @@ x86_64 | arm | x86 | ppc* | ia64)
esac
dnl ========================================================
-dnl = Disable WebRTC code
+dnl = Enable WebRTC code
dnl ========================================================
-MOZ_ARG_DISABLE_BOOL(webrtc,
-[ --disable-webrtc Disable support for WebRTC],
- MOZ_WEBRTC=,
- MOZ_WEBRTC=1)
+MOZ_ARG_ENABLE_BOOL(webrtc,
+[ --enable-webrtc Enable support for WebRTC],
+ MOZ_WEBRTC=1,
+ MOZ_WEBRTC=)
if test -n "$MOZ_WEBRTC"; then
AC_DEFINE(MOZ_WEBRTC)