summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authortrav90 <travawine@protonmail.ch>2017-01-01 20:27:59 -0600
committertrav90 <travawine@protonmail.ch>2017-01-01 20:27:59 -0600
commit83fc635fba0d15dfd6aec28d1056cc3f12cca2a9 (patch)
tree97c59cf44079809d720bcb85321dd4ccf1a61140 /configure.in
parentf01a365042fe50f012c5b7c2566479fca9b7a27c (diff)
downloadpalemoon-gre-83fc635fba0d15dfd6aec28d1056cc3f12cca2a9.tar.gz
Add test/error if building FFmpeg support without FMP4 support
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ab781bf7a..fff8e186e 100644
--- a/configure.in
+++ b/configure.in
@@ -5311,6 +5311,10 @@ MOZ_ARG_DISABLE_BOOL(fmp4,
MOZ_FMP4=,
MOZ_FMP4=1)
+if test -n "$MOZ_FFMPEG" -a -z "$MOZ_FMP4"; then
+ AC_MSG_ERROR([Fragmented MP4 support must be enabled if using FFmpeg])
+fi
+
if test -n "$MOZ_FMP4"; then
AC_DEFINE(MOZ_FMP4)
fi;