summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMoonchild <wolfbeast@users.noreply.github.com>2017-01-03 14:53:58 +0100
committerGitHub <noreply@github.com>2017-01-03 14:53:58 +0100
commit345aa577c7cd48712e22096562730b1bbe34af4a (patch)
tree1bde473312f103487dc07c1c95c622b24a004c1d /configure.in
parentf1ae30b19e1e9ee72af8a7546b54b60d75a84738 (diff)
parent0136abec5a63fefac3ac4b0be3c7bdccb020cc47 (diff)
downloadpalemoon-gre-345aa577c7cd48712e22096562730b1bbe34af4a.tar.gz
Merge pull request #805 from trav90/media-pref-work
Adjust some media prefs
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1e533643a..929f68c64 100644
--- a/configure.in
+++ b/configure.in
@@ -5287,6 +5287,10 @@ MOZ_ARG_DISABLE_BOOL(fmp4,
MOZ_FMP4=,
MOZ_FMP4=1)
+if test -n "$MOZ_FFMPEG" -a -z "$MOZ_FMP4"; then
+ AC_MSG_ERROR([Fragmented MP4 support must be enabled if using FFmpeg])
+fi
+
if test -n "$MOZ_FMP4"; then
AC_DEFINE(MOZ_FMP4)
fi;