summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authortrav90 <travawine@protonmail.ch>2017-02-10 10:39:14 -0600
committertrav90 <travawine@protonmail.ch>2017-02-10 10:39:14 -0600
commit090b8adf6a62c007f4d5d91da73bf1f2b2873c1f (patch)
tree7e87b1dd0f7cb7be48eb55c61877b1a8ad7df501 /configure.in
parent12e61e3c953e18c0fd72489a2d655c4c5698b11a (diff)
downloadpalemoon-gre-090b8adf6a62c007f4d5d91da73bf1f2b2873c1f.tar.gz
Remove GStreamer option from configure
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in52
1 files changed, 0 insertions, 52 deletions
diff --git a/configure.in b/configure.in
index 1ad3cb502..0f468b111 100644
--- a/configure.in
+++ b/configure.in
@@ -3819,7 +3819,6 @@ MOZ_WAVE=1
MOZ_SAMPLE_TYPE_FLOAT32=
MOZ_SAMPLE_TYPE_S16=
MOZ_WEBM=1
-MOZ_GSTREAMER=
MOZ_DIRECTSHOW=
MOZ_WMF=
if test -n "$MOZ_FMP4"; then
@@ -5588,57 +5587,6 @@ fi
AC_SUBST(MOZ_PULSEAUDIO)
dnl ========================================================
-dnl = Enable GStreamer
-dnl ========================================================
-case "$OS_TARGET" in
-WINNT|Darwin|Android)
- ;;
-*)
- MOZ_GSTREAMER=
- ;;
-esac
-
-MOZ_ARG_ENABLE_BOOL(gstreamer,
-[ --enable-gstreamer Enable GStreamer support],
-MOZ_GSTREAMER=1,
-MOZ_GSTREAMER=)
-
-if test "$MOZ_GSTREAMER"; then
- GST_API_VERSION=1.0
- # core/base release number
- GST_VERSION=1.0
-
- PKG_CHECK_MODULES(GSTREAMER,
- gstreamer-$GST_API_VERSION >= $GST_VERSION
- gstreamer-app-$GST_API_VERSION
- gstreamer-plugins-base-$GST_API_VERSION,
- [_HAVE_GSTREAMER=1],
- [_HAVE_GSTREAMER=])
- if test -z "$_HAVE_GSTREAMER"; then
- AC_MSG_ERROR([gstreamer and gstreamer-plugins-base development packages are needed to build gstreamer backend. Install them or disable gstreamer support with --disable-gstreamer])
- fi
-
- _SAVE_LDFLAGS=$LDFLAGS
- LDFLAGS="$LDFLAGS $GSTREAMER_LIBS -lgstvideo-$GST_API_VERSION"
- AC_TRY_LINK(,[return 0;],_HAVE_LIBGSTVIDEO=1,_HAVE_LIBGSTVIDEO=)
- if test -n "$_HAVE_LIBGSTVIDEO" ; then
- GSTREAMER_LIBS="$GSTREAMER_LIBS -lgstvideo-$GST_API_VERSION"
- else
- AC_MSG_ERROR([gstreamer-plugins-base found, but no libgstvideo. Something has gone terribly wrong. Try reinstalling gstreamer-plugins-base; failing that, disable the gstreamer backend with --disable-gstreamer.])
- fi
- LDFLAGS=$_SAVE_LDFLAGS
-fi
-
-AC_SUBST(MOZ_GSTREAMER)
-AC_SUBST(GST_API_VERSION)
-
-if test -n "$MOZ_GSTREAMER"; then
- AC_DEFINE(MOZ_GSTREAMER)
- AC_DEFINE_UNQUOTED(GST_API_VERSION, "$GST_API_VERSION")
-fi
-
-
-dnl ========================================================
dnl Permissions System
dnl ========================================================
MOZ_ARG_DISABLE_BOOL(permissions,