| Commit message (Collapse) | Author | Age |
... | |
| | |
|
| |
| |
| |
| |
| |
| |
| | |
This has been long deprecated in favor of std::unsorted_map. Since all platforms
are using modern compilers now it should not be a problem to switch over to
std::unsorted_map in the single place hash_map is used. This allows us to build
on platforms which have removed hash_map such as FreeBSD.
|
| | |
|
|/
|
|
| |
Resolves #1999
|
|\
| |
| |
| |
| |
| | |
dbsoft/UXP:1990fix2 into master
Reviewed-on: https://repo.palemoon.org/MoonchildProductions/UXP/pulls/1997
|
| |
| |
| |
| |
| | |
If the worker is shut down, call Cancel() on the Runnable, this will prevent
nsInputStreamReadyEvents to be called again when deallocated.
|
| |
| |
| |
| |
| |
| | |
basically copy/pastes of the DOMEventTargetHelper one.
Mozilla Bug Bug 1333540. Skipped the renamed of various functions, but otherwise a direct port.
|
| |
| |
| |
| |
| |
| |
| |
| | |
and 2.
1334081 - prevent null pointer dereference in StreamReaderFunc.
1330631 - Convert the EventSourceImpl::Message to be UniquePtr.
1337619 - Reset mGoingToDispatchAllMessages flag before early return.
|
| |
| |
| |
| | |
nsIThreadRetargetableStreamListener definition.
|
| |
| |
| |
| | |
EventSourceImpl::mEventSource. - Mozilla Bug 1333099
|
| | |
|
| | |
|
|\ \
| | |
| | |
| | |
| | |
| | | |
from dbsoft/UXP:macfixes into master
Reviewed-on: https://repo.palemoon.org/MoonchildProductions/UXP/pulls/1998
|
| | |
| | |
| | |
| | | |
int3 is Intel only, so don't use it on ARM, use __builtin_trap() instead.
|
| |/
| |
| |
| |
| |
| | |
The python binary copied reports a valid signature on Big Sur and thus codesign fails.
Add the -f option so it overwrites the supposedly valid signature. Other versions are
either already unsigned or the install_name_tool invalidates the signature.
|
| |
| |
| |
| | |
Resolves #1996
|
| | |
|
| | |
|
|\ \
| | |
| | |
| | |
| | |
| | | |
Basilisk-Dev/UXP:master into master
Reviewed-on: https://repo.palemoon.org/MoonchildProductions/UXP/pulls/1993
|
| | | |
|
| | |
| | |
| | |
| | | |
Port of Mozilla bug 1383575
|
| |/
| |
| |
| | |
Backport of Mozilla bug 1056934
|
| |
| |
| |
| |
| | |
I've used this setting without ill effects for weeks, including visiting
many a cloudflare-backed site. There is no issue there.
|
|\ \ |
|
| |\ \
| | |/
| |/|
| | |
| | |
| | | |
from athenian200/UXP:flex-container-changes into master
Reviewed-on: https://repo.palemoon.org/MoonchildProductions/UXP/pulls/1987
|
| | |
| | |
| | |
| | |
| | |
| | | |
Almost forgot to do this. This is in case we need to revisit this for
regressions in the future and the tests are not available online. Never know
when they might come in handy again.
|
| | |
| | |
| | |
| | |
| | |
| | |
| | |
| | | |
code.
It turns out part 10 was actually needed, but Bug 1449838 had a significantly
better version of what that code does that was easy enough to backport to what
we have. As far as I can tell, this passes the relevant reftests now.
|
| | |
| | |
| | |
| | |
| | | |
This mostly reworks the way nsFlexContainerFrame handles things so that it can
deal with more than just height.
|
| |/
| |
| |
| |
| |
| | |
Configure was defining HAVE_ARC4RANDOM_BUF on systems that have it this whole
time, so the OS specific ifdefs weren't necessary. Maybe the flag that was in
the original patch was an obsolete name for that flag...
|
|/
|
|
|
|
| |
The current spec makes "implicit" parentheses a thing for feeding
css strings to CSS.supports()
The current spec also implies CSS is a namespace, not an interface
|
|
|
|
|
|
|
|
|
|
| |
My previous fix apparently only worked with GCC 7. Having that return at the
end doesn't seem to hurt anything on Windows, so I see no reason to ifdef it.
I don't remember where I heard this, but I vaguely remember hearing that
ending a function without a return statement may be undefined behavior that
differs between compilers and operating systems. If so, that would explain why
this has behaved so differently across platforms and compilers.
|
|
|
|
| |
This seems to work for me, but I haven't tested anything else yet. Still, seems better to have a fix in the tree than to leave it as-is.
|
|
|
|
|
|
|
|
| |
This was a control issue way back when. Since this only really relates to
deviating build configs anymore and no longer to critical system libs of note,
there's no point in retaining this overbearing control through build errors.
People have clear instructions how to build - it is their responsibility to
stick to those.
|
|
|
|
|
| |
The wildcard seems to work well here for getting files included in the
final target.
|
|\
| |
| |
| |
| |
| | |
from Basilisk-Dev/UXP:master into master
Reviewed-on: https://repo.palemoon.org/MoonchildProductions/UXP/pulls/1983
|
|/ |
|
|\
| |
| |
| |
| |
| | |
is enabled.' (#1981) from jobbautista9/UXP:1980-rtcfix into master
Reviewed-on: https://repo.palemoon.org/MoonchildProductions/UXP/pulls/1981
|
|/
|
|
|
|
|
|
|
|
|
|
|
|
| |
enabled.
Turns out we have a duplicate VoidFunction callback in the WebIDLs. Per
Mozilla bug 1324169, we should remove this callback from
RTCPeerConnection.webidl and let Function.webidl handle it instead.
The AttributeError faced by the new Basilisk dev wasn't helpful at all;
and turns out Mozilla had this exact same issue on bug 1505504. We're
also backporting that just in case we encounter another case of
callback duplication.
Also doing a minor fix in the MicroTaskRunnable class which Moonchild
forgot to do while working on Issue #1895.
|
|\
| |
| |
| |
| |
| | |
cubeb update."' (#1979) from Basilisk-Dev/UXP:master into master
Reviewed-on: https://repo.palemoon.org/MoonchildProductions/UXP/pulls/1979
|
|/
|
|
| |
This reverts commit d0acadd727468ccaa4e3cbe3673e29890c2551ca.
|
|\ |
|
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| | |
The issue is that select elements may contain some non-Latin characters that
need extra block-size to display than the one line-height calculated by using a
Latin font spec in the style.
Before this patch, when a control has an unconstrained block-size, we set
the element's block-size to one line-height in Reflow(), which is intended to
properly initialize `BlockReflowInput::mMinLineHeight` since it uses
`line-height:-moz-block-height`.
However, this simply prevents the display from choosing a larger block-size
after the reflow occurs. Previously, this discrepancy was absorbed by the extra
padding present to make select elements the same intrinsic size as buttons, but
since we did away with that, we're losing the extra space and the font glyphs
get clipped.
This patch fixes the issue by carrying the computed line height over to the
element's display so that its computed block-size is still unconstrained.
This way it can accommodate taller characters in the display text.
After this patch, a <select><option> containing non-Latin characters should have
the same block-size as <button>, and no characters should be clipped.
|
| |
| |
| |
| |
| |
| |
| |
| | |
To better distinguish the calculation of line height (still present with args)
and simply getting the line height without args, it's now called GetLineHeight()
This also introduces `mLineHeight` to cache specifically calculated line heights
that aren't "auto" (which is a magic value), and it opens up the possibility to
override it in Part 7.
|
| |
| |
| |
| |
| | |
This doesn't change behavior by default but allows authors to remove the padding
previously enforced to align with focus ring padding, if they wish to.
|
| | |
|
| | |
|
| |
| |
| |
| |
| |
| | |
Extra padding was created for a prospective -moz-focus-inner ring.
We now just size that ring the same as the content frame, inflated by its CSS
padding.
|
| | |
|
|\ \
| | |
| | |
| | |
| | |
| | |
| | | |
jobbautista9/UXP:1977-wav-videodocument into master
Reviewed-on: https://repo.palemoon.org/MoonchildProductions/UXP/pulls/1978
Reviewed-by: Moonchild <moonchild@palemoon.org>
|
| | |
| | |
| | |
| | |
| | | |
I've thought about this before creating the issue, and Moonchild
wanted this as well.
|