summaryrefslogtreecommitdiff
path: root/system/slpkg/slpkg.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/slpkg/slpkg.SlackBuild')
-rw-r--r--system/slpkg/slpkg.SlackBuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/system/slpkg/slpkg.SlackBuild b/system/slpkg/slpkg.SlackBuild
index 735e682df2..e31207da55 100644
--- a/system/slpkg/slpkg.SlackBuild
+++ b/system/slpkg/slpkg.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=slpkg
-VERSION=${VERSION:-3.2.0}
+VERSION=${VERSION:-3.2.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -56,6 +56,9 @@ fi
set -e
+PYTHON=python
+[ "${PYTHON3:-no}" = "yes" ] && PYTHON=python3
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
@@ -72,7 +75,13 @@ find -L . \
# avoid install configuration files and man page over setup.py
sed -i 's/if "install"/if ""/' setup.py
-python setup.py install --root=$PKG
+# Python 3 support
+if [ "$PYTHON3" = "yes" ]; then
+ sh convert-py3k
+ cd py3k/$PRGNAM
+fi
+
+$PYTHON setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true