summaryrefslogtreecommitdiff
path: root/system/rodent/rodent.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/rodent/rodent.SlackBuild')
-rw-r--r--system/rodent/rodent.SlackBuild51
1 files changed, 31 insertions, 20 deletions
diff --git a/system/rodent/rodent.SlackBuild b/system/rodent/rodent.SlackBuild
index 99737aef8d..098e482997 100644
--- a/system/rodent/rodent.SlackBuild
+++ b/system/rodent/rodent.SlackBuild
@@ -2,10 +2,29 @@
# Slackware build script for rodent
-# Written by Roberto Neri <rneri@libero.it>
+# Copyright 2011-2012 Roberto Neri, Palermo, Italy
+#
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=rodent
-VERSION=${VERSION:-4.7.4}
+VERSION=${VERSION:-4.8.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -36,10 +55,9 @@ else
LIBDIRSUFFIX=""
fi
-# All plugins are enabled, since they haven't extra dependencies, except
-# for the gvfs plugin, which is disabled by default but can be enabled
-# by passing GVFS=yes to the script
-GVFS=${GVFS:-no}
+# The experimental plugins are disabled by default but can be enabled
+# by passing EXPERIMENTAL=yes to the script
+EXPERIMENTAL=${EXPERIMENTAL:-no}
set -e
@@ -56,7 +74,7 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Fix ./configure typos
+# Fix Build/plugins/Makefile
patch -p1 < $CWD/$PRGNAM-$VERSION.diff
CFLAGS="$SLKCFLAGS" \
@@ -66,25 +84,18 @@ CXXFLAGS="$SLKCFLAGS" \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--mandir=/usr/man \
--docdir=/usr/doc/$PRGNAM-$VERSION \
- --enable-icontheme=yes \
- --enable-gvfsplugin=$GVFS \
- --enable-propertiesplugin=yes \
- --enable-fgrplugin=yes \
- --enable-mimeplugin=yes \
- --enable-iconsplugin=yes \
- --enable-comboboxplugin=yes \
- --enable-settingsplugin=yes \
- --enable-fstabplugin=yes \
- --enable-psplugin=yes \
- --enable-dotdesktopplugin=yes \
+ --enable-experimental=$EXPERIMENTAL \
--build=$ARCH-slackware-linux
make
-# Note: the manual (RTFM.pdf) is installed in /usr/share/doc/rfm-Gamma
+# Note: the manual (RTFM.pdf) is installed in /usr/share/doc/rfm-Delta
# This could be overridden by passing docdir=/usr/doc/$PRGNAM-$VERSION
# to "make install", but that would break the "Help" function, so it's
# better to leave it in its non-standard location
+# =========
+# Yes, but that's a bug. Edscott should fix that. :)
+# --rworkman
make install DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
@@ -95,7 +106,7 @@ for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; r
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- AUTHORS ChangeLog COPYING INSTALL NEWS README TODO \
+ AUTHORS ChangeLog COPYING INSTALL NEWS README TODO WISHLIST \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild