summaryrefslogtreecommitdiff
path: root/system/redis/redis.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/redis/redis.SlackBuild')
-rw-r--r--system/redis/redis.SlackBuild15
1 files changed, 3 insertions, 12 deletions
diff --git a/system/redis/redis.SlackBuild b/system/redis/redis.SlackBuild
index e524d3488b..8af4397f7d 100644
--- a/system/redis/redis.SlackBuild
+++ b/system/redis/redis.SlackBuild
@@ -24,7 +24,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=redis
-VERSION=${VERSION:-2.8.19}
+VERSION=${VERSION:-3.0.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -76,17 +76,7 @@ sed -i "s|-O3||" deps/Makefile deps/hiredis/Makefile
# No ./configure necessary.
# http://lists.slackbuilds.org/pipermail/slackbuilds-users/2013-January/010042.html
( unset ARCH ; CFLAGS="$SLKCFLAGS" make )
-
-# Install binaries.
-mkdir -p $PKG/usr/bin
-( cd src
- install -m 0755 \
- redis-server redis-cli redis-benchmark redis-check-aof redis-check-dump \
- $PKG/usr/bin
-)
-
-# Create symlink to start redis in sentinel mode.
-( cd $PKG/usr/bin ; ln -sf redis-server redis-sentinel )
+make install PREFIX=$PKG/usr
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -99,6 +89,7 @@ sed -i \
-e 's|^logfile ""|logfile /var/log/redis/redis.log|' \
-e 's|^# bind 127.0.0.1|bind 127.0.0.1|' \
$PKG/etc/redis/redis.conf.new
+install -D -m 0644 sentinel.conf $PKG/etc/redis/sentinel.conf.new
# Create data directory.
mkdir -p $PKG/var/lib/redis