summaryrefslogtreecommitdiff
path: root/system/pycp/pycp.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/pycp/pycp.SlackBuild')
-rw-r--r--system/pycp/pycp.SlackBuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/system/pycp/pycp.SlackBuild b/system/pycp/pycp.SlackBuild
index f0f2e3ea1d..342aab886a 100644
--- a/system/pycp/pycp.SlackBuild
+++ b/system/pycp/pycp.SlackBuild
@@ -2,7 +2,7 @@
#
# Slackware build script for pycp.
#
-# Copyright 2015-2017 Edinaldo P. Silva, Rio de Janeiro, Brazil.
+# Copyright 2015-2019 Edinaldo P. Silva, Rio de Janeiro, Brazil.
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pycp
-VERSION=${VERSION:-7.3.0}
+VERSION=${VERSION:-8.0.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -55,12 +55,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG --optimize=1
+python3 setup.py build
+python3 setup.py install --root=$PKG --optimize=1
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-DOCS="AUTHORS Changelog.rst COPYING.txt README.rst TODO"
+DOCS="AUTHORS Changelog.rst COPYING.txt README.rst TODO.md"
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp $DOCS $PKG/usr/doc/$PRGNAM-$VERSION