summaryrefslogtreecommitdiff
path: root/system/pommed/patches/pommed-1.26-use_custom_cflags.diff
diff options
context:
space:
mode:
Diffstat (limited to 'system/pommed/patches/pommed-1.26-use_custom_cflags.diff')
-rw-r--r--system/pommed/patches/pommed-1.26-use_custom_cflags.diff55
1 files changed, 55 insertions, 0 deletions
diff --git a/system/pommed/patches/pommed-1.26-use_custom_cflags.diff b/system/pommed/patches/pommed-1.26-use_custom_cflags.diff
new file mode 100644
index 0000000000..2473d41d61
--- /dev/null
+++ b/system/pommed/patches/pommed-1.26-use_custom_cflags.diff
@@ -0,0 +1,55 @@
+diff -Nur pommed-1.26.orig/gpomme/Makefile pommed-1.26/gpomme/Makefile
+--- pommed-1.26.orig/gpomme/Makefile 2009-03-14 08:13:17.000000000 -0500
++++ pommed-1.26/gpomme/Makefile 2009-07-29 11:13:21.054859107 -0500
+@@ -1,4 +1,5 @@
+ CC = gcc
++OPT ?= -O2
+
+ GTK_CFLAGS = $(shell pkg-config --cflags gtk+-2.0)
+ GTK_LIBS = $(shell pkg-config --libs gtk+-2.0)
+@@ -17,7 +18,7 @@
+
+ INOTIFY_CFLAGS = $(shell test -e /usr/include/sys/inotify.h || echo -DNO_SYS_INOTIFY_H)
+
+-CFLAGS = -g -O2 -Wall $(DBUS_CFLAGS) $(DBUSGLIB_CFLAGS) $(GTK_CFLAGS) $(CONFUSE_CFLAGS) $(GLADE_CFLAGS) $(INOTIFY_CFLAGS)
++CFLAGS = -g $(OPT) -Wall $(DBUS_CFLAGS) $(DBUSGLIB_CFLAGS) $(GTK_CFLAGS) $(CONFUSE_CFLAGS) $(GLADE_CFLAGS) $(INOTIFY_CFLAGS)
+ LDFLAGS = -lpthread $(DBUS_LIBS) $(DBUSGLIB_LIBS) $(GTK_LIBS) $(CONFUSE_LIBS) $(GLADE_LIBS)
+
+ SOURCES = gpomme.c theme.c conffile.c \
+diff -Nur pommed-1.26.orig/pommed/Makefile pommed-1.26/pommed/Makefile
+--- pommed-1.26.orig/pommed/Makefile 2009-03-14 08:13:17.000000000 -0500
++++ pommed-1.26/pommed/Makefile 2009-07-29 11:13:34.453703569 -0500
+@@ -1,6 +1,7 @@
+ ARCH ?= $(shell uname -m)
+
+ CC = gcc
++OPT ?= -O2
+
+ DBUS_CFLAGS = $(shell pkg-config dbus-1 --cflags) -DDBUS_API_SUBJECT_TO_CHANGE
+ DBUS_LIBS = $(shell pkg-config dbus-1 --libs)
+@@ -18,7 +19,7 @@
+
+ TIMERFD_CFLAGS = $(shell test -e /usr/include/sys/timerfd.h || echo -DNO_SYS_TIMERFD_H)
+
+-CFLAGS = -g -O2 -Wall $(DBUS_CFLAGS) $(ALSA_CFLAGS) $(AUDIOFILE_CFLAGS) $(CONFUSE_CFLAGS) $(INOTIFY_CFLAGS) $(TIMERFD_CFLAGS)
++CFLAGS = -g $(OPT) -Wall $(DBUS_CFLAGS) $(ALSA_CFLAGS) $(AUDIOFILE_CFLAGS) $(CONFUSE_CFLAGS) $(INOTIFY_CFLAGS) $(TIMERFD_CFLAGS)
+
+ LDFLAGS = -pthread -lrt $(DBUS_LIBS) $(ALSA_LIBS) $(AUDIOFILE_LIBS) $(CONFUSE_LIBS)
+
+diff -Nur pommed-1.26.orig/wmpomme/Makefile pommed-1.26/wmpomme/Makefile
+--- pommed-1.26.orig/wmpomme/Makefile 2009-03-14 08:13:17.000000000 -0500
++++ pommed-1.26/wmpomme/Makefile 2009-07-29 11:13:46.671562196 -0500
+@@ -1,11 +1,12 @@
+ CC = gcc
++OPT ?= -O2
+
+ DBUS_CFLAGS = $(shell pkg-config dbus-1 --cflags) -DDBUS_API_SUBJECT_TO_CHANGE
+ DBUS_LIBS = $(shell pkg-config dbus-1 --libs)
+
+ TIMERFD_CFLAGS = $(shell test -e /usr/include/sys/timerfd.h || echo -DNO_SYS_TIMERFD_H)
+
+-CFLAGS = -g -O2 -Wall $(DBUS_CFLAGS) $(TIMERFD_CFLAGS)
++CFLAGS = -g $(OPT) -Wall $(DBUS_CFLAGS) $(TIMERFD_CFLAGS)
+ LDFLAGS = -lrt -lXpm -lXext -lX11 $(DBUS_LIBS)
+
+ SOURCES = wmgeneral.c wmpomme.c \