summaryrefslogtreecommitdiff
path: root/system/kvm/kvm-88-no_trickery_on_install.patch
diff options
context:
space:
mode:
Diffstat (limited to 'system/kvm/kvm-88-no_trickery_on_install.patch')
-rw-r--r--system/kvm/kvm-88-no_trickery_on_install.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/system/kvm/kvm-88-no_trickery_on_install.patch b/system/kvm/kvm-88-no_trickery_on_install.patch
new file mode 100644
index 0000000000..c93c1e54df
--- /dev/null
+++ b/system/kvm/kvm-88-no_trickery_on_install.patch
@@ -0,0 +1,15 @@
+diff -Nur kvm-88.orig/kvm/kernel/Makefile kvm-88/kvm/kernel/Makefile
+--- kvm-88.orig/kvm/kernel/Makefile 2009-07-12 08:19:45.000000000 -0500
++++ kvm-88/kvm/kernel/Makefile 2009-10-05 16:11:50.668418494 -0500
+@@ -49,11 +49,6 @@
+ install:
+ mkdir -p $(DESTDIR)/$(INSTALLDIR)
+ cp $(ARCH_DIR)/*.ko $(DESTDIR)/$(INSTALLDIR)
+- for i in $(ORIGMODDIR)/drivers/kvm/*.ko \
+- $(ORIGMODDIR)/arch/$(ARCH_DIR)/kvm/*.ko; do \
+- if [ -f "$$i" ]; then mv "$$i" "$$i.orig"; fi; \
+- done
+- /sbin/depmod -a $(DEPMOD_VERSION)
+
+ tmpspec = .tmp.kvm-kmod.spec
+