summaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
Diffstat (limited to 'python')
-rw-r--r--python/pygame/pygame.SlackBuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/python/pygame/pygame.SlackBuild b/python/pygame/pygame.SlackBuild
index 9267ec0cdb..e35ca2750d 100644
--- a/python/pygame/pygame.SlackBuild
+++ b/python/pygame/pygame.SlackBuild
@@ -2,11 +2,12 @@
## Written by hollywoodb (hollywoodb@fastmail.fm)
# Modified by the SlackBuilds.org project
-# Modified by Bojan Popovic (bocke@slackware-srbija.org), 2014.
+# Maintained by Bojan Popovic (bocke@slackware-srbija.org), 2014-2017
+# Contribution by B.Watson (yalhcru@gmail.com), 11 apr. 2017.
PRGNAM=pygame
VERSION=${VERSION:-1.9.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -52,6 +53,11 @@ find -L . \
# A patch borrowed from Arch community repo
patch -p1 < $CWD/pygame-v4l.patch
+# Contributed by B.Watson (yalhcru@gmail.com).
+# Gets rid of the call to remove_old_files() during packaging.
+# TLDR: Stops packaging scripts from messing with a local PyGame install.
+sed -i '/^if "install"/,$d' setup.py
+
python -u config.py
CFLAGS="$SLKCFLAGS" \
python setup.py install --root=$PKG