summaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
Diffstat (limited to 'python')
-rw-r--r--python/URLObject/slack-desc19
-rw-r--r--python/python3-urlobject/README (renamed from python/URLObject/README)0
-rw-r--r--python/python3-urlobject/python3-urlobject.SlackBuild (renamed from python/URLObject/URLObject.SlackBuild)14
-rw-r--r--python/python3-urlobject/python3-urlobject.info (renamed from python/URLObject/URLObject.info)4
-rw-r--r--python/python3-urlobject/slack-desc19
5 files changed, 27 insertions, 29 deletions
diff --git a/python/URLObject/slack-desc b/python/URLObject/slack-desc
deleted file mode 100644
index d0a65ba786..0000000000
--- a/python/URLObject/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-URLObject: URLObject (utility class for manipulating URLs)
-URLObject:
-URLObject: The latest incarnation of this library builds upon the ideas of its
-URLObject: predecessor, but aims for a clearer API, focusing on proper method
-URLObject: names over operator overrides.
-URLObject:
-URLObject: It's also being developed from the ground up in a test-driven manner,
-URLObject: and has full Sphinx documentation.
-URLObject:
-URLObject:
-URLObject:
diff --git a/python/URLObject/README b/python/python3-urlobject/README
index cc6220c9fb..cc6220c9fb 100644
--- a/python/URLObject/README
+++ b/python/python3-urlobject/README
diff --git a/python/URLObject/URLObject.SlackBuild b/python/python3-urlobject/python3-urlobject.SlackBuild
index be9d96eec8..784e36d419 100644
--- a/python/URLObject/URLObject.SlackBuild
+++ b/python/python3-urlobject/python3-urlobject.SlackBuild
@@ -22,7 +22,8 @@
cd $(dirname $0) ; CWD=$(pwd)
-PRGNAM=URLObject
+PRGNAM=python3-urlobject
+SRCNAM=URLObject
VERSION=${VERSION:-2.4.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -53,9 +54,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -63,10 +64,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README.rst MANIFEST.in $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/python/URLObject/URLObject.info b/python/python3-urlobject/python3-urlobject.info
index a4cc180092..f7afc7ab56 100644
--- a/python/URLObject/URLObject.info
+++ b/python/python3-urlobject/python3-urlobject.info
@@ -1,6 +1,6 @@
-PRGNAM="URLObject"
+PRGNAM="python3-urlobject"
VERSION="2.4.3"
-HOMEPAGE="http://github.com/zacharyvoase/urlobject"
+HOMEPAGE="https://github.com/zacharyvoase/urlobject"
DOWNLOAD="https://pypi.python.org/packages/source/U/URLObject/URLObject-2.4.3.tar.gz"
MD5SUM="bbce110483eda19da3008f929d02dc98"
DOWNLOAD_x86_64=""
diff --git a/python/python3-urlobject/slack-desc b/python/python3-urlobject/slack-desc
new file mode 100644
index 0000000000..9a7715e53b
--- /dev/null
+++ b/python/python3-urlobject/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-urlobject: python3-urlobject (utility class for manipulating URLs)
+python3-urlobject:
+python3-urlobject: The latest incarnation of this library builds upon the ideas of its
+python3-urlobject: predecessor, but aims for a clearer API, focusing on proper method
+python3-urlobject: names over operator overrides.
+python3-urlobject:
+python3-urlobject: It's also being developed from the ground up in a test-driven manner,
+python3-urlobject: and has full Sphinx documentation.
+python3-urlobject:
+python3-urlobject:
+python3-urlobject: