summaryrefslogtreecommitdiff
path: root/python/python3/patches/python3.no-static-library.diff
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3/patches/python3.no-static-library.diff')
-rw-r--r--python/python3/patches/python3.no-static-library.diff14
1 files changed, 7 insertions, 7 deletions
diff --git a/python/python3/patches/python3.no-static-library.diff b/python/python3/patches/python3.no-static-library.diff
index 2af8b2ffcc..c33aeedcf7 100644
--- a/python/python3/patches/python3.no-static-library.diff
+++ b/python/python3/patches/python3.no-static-library.diff
@@ -1,7 +1,7 @@
-diff -uar Python-3.5.0.orig/Makefile.pre.in Python-3.5.0/Makefile.pre.in
---- Python-3.5.0.orig/Makefile.pre.in 2015-09-13 14:41:23.000000000 +0300
-+++ Python-3.5.0/Makefile.pre.in 2015-10-25 16:33:56.191130269 +0200
-@@ -549,7 +549,7 @@
+diff -uar Python-3.5.1.orig/Makefile.pre.in Python-3.5.1/Makefile.pre.in
+--- Python-3.5.1.orig/Makefile.pre.in 2015-12-07 03:39:09.000000000 +0200
++++ Python-3.5.1/Makefile.pre.in 2015-12-14 21:25:22.103542432 +0200
+@@ -564,7 +564,7 @@
$(RUNSHARED) $(PYTHON_FOR_BUILD) ./Tools/clinic/clinic.py --make
# Build the interpreter
@@ -10,7 +10,7 @@ diff -uar Python-3.5.0.orig/Makefile.pre.in Python-3.5.0/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
platform: $(BUILDPYTHON) pybuilddir.txt
-@@ -584,18 +584,6 @@
+@@ -599,18 +599,6 @@
_TCLTK_INCLUDES='$(TCLTK_INCLUDES)' _TCLTK_LIBS='$(TCLTK_LIBS)' \
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
@@ -29,7 +29,7 @@ diff -uar Python-3.5.0.orig/Makefile.pre.in Python-3.5.0/Makefile.pre.in
libpython$(LDVERSION).so: $(LIBRARY_OBJS)
if test $(INSTSONAME) != $(LDLIBRARY); then \
$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
-@@ -685,7 +673,7 @@
+@@ -700,7 +688,7 @@
echo "-----------------------------------------------"; \
fi
@@ -38,7 +38,7 @@ diff -uar Python-3.5.0.orig/Makefile.pre.in Python-3.5.0/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
############################################################################
-@@ -1357,18 +1345,6 @@
+@@ -1372,18 +1360,6 @@
else true; \
fi; \
done