summaryrefslogtreecommitdiff
path: root/python/pydot/pydot.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pydot/pydot.SlackBuild')
-rw-r--r--python/pydot/pydot.SlackBuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/python/pydot/pydot.SlackBuild b/python/pydot/pydot.SlackBuild
index a52d53da03..7340086fbe 100644
--- a/python/pydot/pydot.SlackBuild
+++ b/python/pydot/pydot.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pydot
-# Copyright 2009 Heinz Wiesinger <pprkut@liwjatan.at>
+# Copyright 2009-2011 Heinz Wiesinger, Amsterdam, The Netherlands
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,16 +23,14 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pydot
-VERSION=1.0.2
+VERSION=1.0.23
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -60,13 +58,13 @@ find . \
python setup.py install --root=$PKG
# remove wrongly installed docs
-rm -f $PKG/usr/{ChangeLog,LICENSE,README}
+rm -f $PKG/usr/{LICENSE,README}
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ChangeLog LICENSE PKG-INFO README \
+cp -a LICENSE PKG-INFO README \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild