summaryrefslogtreecommitdiff
path: root/python/imagesize/imagesize.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/imagesize/imagesize.SlackBuild')
-rw-r--r--python/imagesize/imagesize.SlackBuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/python/imagesize/imagesize.SlackBuild b/python/imagesize/imagesize.SlackBuild
index 34a8c915cd..4b9a50d00f 100644
--- a/python/imagesize/imagesize.SlackBuild
+++ b/python/imagesize/imagesize.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for imagesize
-# Copyright 2017 Nikos Giotis <nikos.giotis@gmail.com>
+# Copyright 2017,2018 Nikos Giotis <nikos.giotis@gmail.com>, Athens, GR
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=imagesize
VERSION=${VERSION:-0.7.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -71,6 +71,10 @@ find -L . \
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true