summaryrefslogtreecommitdiff
path: root/python/boto/boto.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/boto/boto.SlackBuild')
-rw-r--r--python/boto/boto.SlackBuild25
1 files changed, 20 insertions, 5 deletions
diff --git a/python/boto/boto.SlackBuild b/python/boto/boto.SlackBuild
index e4519950a2..c4631f2412 100644
--- a/python/boto/boto.SlackBuild
+++ b/python/boto/boto.SlackBuild
@@ -2,10 +2,28 @@
# Slackware build script for boto
-# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2011-2013 Larry Hajali <larryhaja[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=boto
-VERSION=${VERSION:-2.6.0}
+VERSION=${VERSION:-2.12.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -39,9 +57,6 @@ find . \
python setup.py install --root=$PKG
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a Changelog.rst PKG-INFO README.rst docs/*.pdf $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/README.$PRGNAM > $PKG/usr/doc/$PRGNAM-$VERSION/README.$PRGNAM