summaryrefslogtreecommitdiff
path: root/office/zathura/zathura.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'office/zathura/zathura.SlackBuild')
-rw-r--r--office/zathura/zathura.SlackBuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/office/zathura/zathura.SlackBuild b/office/zathura/zathura.SlackBuild
index b5cbf77734..6cbcee77e2 100644
--- a/office/zathura/zathura.SlackBuild
+++ b/office/zathura/zathura.SlackBuild
@@ -22,6 +22,12 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20180102 bkw:
+# - Updated for v0.3.8. Have to do some fudging to get it to build with
+# Slack 14.2's older glib2: upstream claims they need 2.50, but the
+# only thing they seem to need it for is the --dependency-file option
+# to glib-compile-resources, which turns out to be unneeded.
+
# 20170711 bkw:
# - BUILD=2
# - Include API docs in package
@@ -60,8 +66,8 @@
# - fix homepage URL
PRGNAM=zathura
-VERSION=${VERSION:-0.3.7}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-0.3.8}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -97,7 +103,7 @@ set -eu
# plugins. This build includes the default PDF plugin, without which zathura
# is completely useless.
PLUGIN=$PRGNAM-pdf-poppler
-PLUGINVER=${PLUGINVER:-0.2.7}
+PLUGINVER=${PLUGINVER:-0.2.8}
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -142,12 +148,13 @@ patch -p1 < $CWD/dlopen_hack.diff
sed -i "s/-pedantic/$SLKCFLAGS/" config.mk
sed -i '/-fdiagnostics-color/d' colors.mk
+sed -i '/--dependency-file/d' Makefile
# 20170711 bkw: git tarballs don't include prebuilt man pages, and I do NOT
# want Sphinx and its 15+ deps as a dep for this build. So:
cp -r $CWD/man doc/_build
-make LIBDIR=/usr/lib$LIBDIRSUFFIX
+make LIBDIR=/usr/lib$LIBDIRSUFFIX GLIB_VERSION_CHECK=0
make install LIBDIR=/usr/lib$LIBDIRSUFFIX MANPREFIX=/usr/man DESTDIR=$PKG RSTTOMAN=""
gzip $PKG/usr/man/man?/*.?