summaryrefslogtreecommitdiff
path: root/network
diff options
context:
space:
mode:
Diffstat (limited to 'network')
-rw-r--r--network/js/README9
-rw-r--r--network/js/dynamic-link.patch13
-rw-r--r--network/js/js.SlackBuild87
-rw-r--r--network/js/js.info10
-rw-r--r--network/js/slack-desc19
5 files changed, 0 insertions, 138 deletions
diff --git a/network/js/README b/network/js/README
deleted file mode 100644
index ace5020d4b..0000000000
--- a/network/js/README
+++ /dev/null
@@ -1,9 +0,0 @@
-SpiderMonkey, Mozilla's JavaScript Engine
-
-SpiderMonkey is the code-name for the Mozilla's C implementation of
-JavaScript. It can be used by applications such as elinks and others.
-
-This is the standalone version of the engine used by Firefox and other
-Mozilla applications.
-
-See README.html in the package's documentation directory for examples.
diff --git a/network/js/dynamic-link.patch b/network/js/dynamic-link.patch
deleted file mode 100644
index 5a62c74fbb..0000000000
--- a/network/js/dynamic-link.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- js.orig/src/Makefile.ref 2006-07-26 20:16:47.000000000 +0100
-+++ js/src/Makefile.ref 2009-01-03 19:05:28.000000000 +0000
-@@ -335,8 +335,8 @@
- $(PROGRAM): $(PROG_OBJS) $(LIBRARY)
- link.exe -out:"$@" $(EXE_LINK_FLAGS) $^
- else
--$(PROGRAM): $(PROG_OBJS) $(LIBRARY)
-- $(CC) -o $@ $(CFLAGS) $(PROG_OBJS) $(LIBRARY) $(LDFLAGS) $(OTHER_LIBS) \
-+$(PROGRAM): $(PROG_OBJS) $(SHARED_LIBRARY)
-+ $(CC) -o $@ $(CFLAGS) $(PROG_OBJS) $(LIBRARY) $(LDFLAGS) -L$(OBJDIR) -ljs $(OTHER_LIBS) \
- $(PROG_LIBS)
- endif
-
diff --git a/network/js/js.SlackBuild b/network/js/js.SlackBuild
deleted file mode 100644
index 0576867bbe..0000000000
--- a/network/js/js.SlackBuild
+++ /dev/null
@@ -1,87 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for SpiderMonkey
-
-# Written by David Woodfall dave@unrealize.co.uk
-# aka dive irc.freenode.net #slackware & #slackbuilds
-
-# Feel free to edit this script as you feel fit but
-# please acknowledge me somewhere in it and contact
-# me if you make any nice improvements.
-
-PRGNAM=js
-VERSION=${VERSION:-1.8.0_rc1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRC_VERSION=$(echo $VERSION | tr _ -)
-
-# Automatically determine the architecture we're building on:
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-CFLAGS="$SLKCFLAGS"
-CXXFLAGS="$SLKCFLAGS"
-XLDFLAGS="-s"
-OPTIMIZER="$SLKCFLAGS"
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM
-tar xvf $CWD/$PRGNAM-$SRC_VERSION.tar.gz
-cd $PRGNAM
-chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-patch -p1 < $CWD/dynamic-link.patch
-
-cd src
-gmake -f Makefile.ref all export BUILD_OPT=1
-
-mv -v ../../dist $PKG/usr
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp ../README README.html $PKG/usr/doc/$PRGNAM-$VERSION/
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/js/js.info b/network/js/js.info
deleted file mode 100644
index 9c7acd7644..0000000000
--- a/network/js/js.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="js"
-VERSION="1.8.0_rc1"
-HOMEPAGE="http://www.mozilla.org/js/spidermonkey/"
-DOWNLOAD="http://ftp.mozilla.org/pub/mozilla.org/js/js-1.8.0-rc1.tar.gz"
-MD5SUM="eaad8815dcc66a717ddb87e9724d964e"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="David Woodfall"
-EMAIL="dave@unrealize.co.uk"
diff --git a/network/js/slack-desc b/network/js/slack-desc
deleted file mode 100644
index 9727f550e2..0000000000
--- a/network/js/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-js: SpiderMonkey (Mozilla's JavaScript Engine)
-js:
-js: SpiderMonkey is the code-name for the Mozilla's C implementation of
-js: JavaScript. It can be used by applications such as elinks and others.
-js:
-js: This is the standalone version of the engine used by Firefox and other
-js: Mozilla applications.
-js:
-js: Homepage: http://www.mozilla.org/js/spidermonkey
-js:
-js: