summaryrefslogtreecommitdiff
path: root/network
diff options
context:
space:
mode:
Diffstat (limited to 'network')
-rw-r--r--network/ndiswrapper-utils/README9
-rw-r--r--network/ndiswrapper-utils/ndiswrapper-utils.SlackBuild97
-rw-r--r--network/ndiswrapper-utils/ndiswrapper-utils.info10
-rw-r--r--network/ndiswrapper-utils/slack-desc19
4 files changed, 0 insertions, 135 deletions
diff --git a/network/ndiswrapper-utils/README b/network/ndiswrapper-utils/README
deleted file mode 100644
index a2435f053c..0000000000
--- a/network/ndiswrapper-utils/README
+++ /dev/null
@@ -1,9 +0,0 @@
-ndiswrapper-utils (userspace utils for using NDIS drivers)
-
-Some vendors do not release specifications of the hardware or
-providea linux driver for their wireless network cards. This
-project provides a linux kernel module that loads and runs NDIS
-(Windows network driver API) drivers supplied by the vendors.
-
-Be sure to read the INSTALL file in the package's documentation
-directory for instructions on configuring your wireless card.
diff --git a/network/ndiswrapper-utils/ndiswrapper-utils.SlackBuild b/network/ndiswrapper-utils/ndiswrapper-utils.SlackBuild
deleted file mode 100644
index 26b31e1330..0000000000
--- a/network/ndiswrapper-utils/ndiswrapper-utils.SlackBuild
+++ /dev/null
@@ -1,97 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for ndiswrapper
-
-# Copyright 2007 Martin Lefebvre <dadexter@sekurity.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# Maintained by Robby Workman <rworkman@slackbuilds.org> now
-
-PRGNAM=ndiswrapper-utils
-VERSION=${VERSION:-1.59}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRCNAM=ndiswrapper
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Teach Makefile to accept our CFLAGS
-sed "/^CFLAGS/s/=/+=/" -i utils/Makefile
-
-CFLAGS="$SLKCFLAGS" make -C utils
-make -C utils install DESTDIR=$PKG \
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/man/man8
-cp ndiswrapper.8 loadndisdriver.8 $PKG/usr/man/man8
-gzip -9 $PKG/usr/man/man8/*.8
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS ChangeLog INSTALL README $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/ndiswrapper-utils/ndiswrapper-utils.info b/network/ndiswrapper-utils/ndiswrapper-utils.info
deleted file mode 100644
index 3880b8e4c8..0000000000
--- a/network/ndiswrapper-utils/ndiswrapper-utils.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="ndiswrapper-utils"
-VERSION="1.59"
-HOMEPAGE="http://sourceforge.net/projects/ndiswrapper/"
-DOWNLOAD="http://downloads.sourceforge.net/ndiswrapper/ndiswrapper-1.59.tar.gz"
-MD5SUM="e26a7213468ccd6b0bb4c211c7aadeaa"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="ndiswrapper-kernel"
-MAINTAINER="Robby Workman"
-EMAIL="rworkman@slackbuilds.org"
diff --git a/network/ndiswrapper-utils/slack-desc b/network/ndiswrapper-utils/slack-desc
deleted file mode 100644
index ef2f81742a..0000000000
--- a/network/ndiswrapper-utils/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-ndiswrapper-utils: ndiswrapper-utils (userspace utilities for using NDIS drivers)
-ndiswrapper-utils:
-ndiswrapper-utils: Some vendors do not release specifications of the hardware or
-ndiswrapper-utils: providea linux driver for their wireless network cards. This
-ndiswrapper-utils: project provides a linux kernel module that loads and runs NDIS
-ndiswrapper-utils: (Windows network driver API) drivers supplied by the vendors.
-ndiswrapper-utils:
-ndiswrapper-utils:
-ndiswrapper-utils:
-ndiswrapper-utils:
-ndiswrapper-utils: